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Overview

This document provides a written 
description of a demonstration of 
various NX meshing capabilities. The 
model will be made from a simple 
generic circuit card geometry file.

This tutorial is part one of a three-
part NX CAE tutorial series.

Software:
NX 10.0

Difficulty Level:
Intermediate

Preceding Tutorial:
None

Input Files Required:
electronics_box_assy.prt
housing_proe.prt
bracket_proe.prt
d_connector_proe.prt

This tutorial is part of a series of free Siemens PLM 
Software training resources provided by ATA. 
For more tutorials, whitepapers, videos, and 
macros, visit ATA’s PLM Software website: 
http://www.ata-plmsoftware.com/resources.

http://www.ata-plmsoftware.com/resources
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Concepts
•	 NX 10.0 basics

•	 Geometry idealization

•	 Midsurfacing

•	 Tetrahedral meshing

•	 Brick meshing

•	 Shell meshing

•	 1D and 0D meshing

•	 Mesh controls

•	 Model checks
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Tutorial

1.	 Introduction
This document provides a written description of a demonstration of 
advanced computer-aided engineering (CAE) for NX 10. The model is 
a simple generic circuit card mounted to a housing with a bracket and 
D-connectors. The housing mounts to a sheet metal bracket, which also 
supports three identical D-connectors.

This introductory section is provided for background only. Sections 1.1 
and 1.2 demonstrate creating a new part file and importing geometry, 
while the remainder of section 1 explains view manipulation and 
introduces the user interface. Alternatively, the assembly part can be 
directly loaded by opening “electronics_box_assy.prt,” and the user can 
advance to section 2.

1.1.	 Create a New File

1.	 Open NX and click the New icon on the upper toolbar or go to 	
	 Menu: File → New
2.	 In the Model tab, set units to inches.
3.	 Change the name to electronics_box_assy.prt.
4.	 Change the folder to whatever is desired. 
5.	 Click OK.

Figure 1-1: ▶ 
NX demonstration model.
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1.2.	 Import an Assembly

1.	 Menu → File → Import → Part
2.	 Click OK and browse for the electronics box assembly part and 	
	 select the latest revision.
3.	 Click OK in the Point dialogue box to place the assembly at the 	
	 origin.
4.	 Click cancel to exit the Point dialogue box.

1.3.	 Change to Full Screen Mode

1.	 Menu: View → Full Screen OR Alt + Enter OR click the icon just 		
	 above the graphics window on the right. The same commands 	
	 can be used to exit full screen mode.

1.4.	 Manipulate the Model

•	 Pan – The view will pan using either of these methods:

1. 	 Holding down the Shift key and the mouse scroll wheel 		
	 while moving the mouse.
2. 	 Holding down the mouse scroll wheel and the right 			 
	 mouse button while moving the mouse.

•	 Zoom – The view will zoom in and out using any one of these 		
	 three methods:

1.	 Rotating the mouse scroll wheel. 
2.	 Holding down the Ctrl key and the mouse scroll wheel while 		
	 moving the mouse.
3.	 Holding down the mouse scroll wheel and the left mouse 		
	 button while moving the mouse.

Figure 1-2: ▶
Import Part dialog box.
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•	 Rotate – The view will rotate using any one of these three methods:

1.	 Holding down the mouse scroll wheel while moving the mouse.
2.	 Holding down the Alt key and mouse scroll wheel while moving 	
	 the mouse.
3.	 F8 key – Pressing F8 will orient the model to the nearest 		
	 orthographic view.

1.5.	 Bring Up the Command Finder Tool

Because NX contains many commands across a number of various 
interfaces, the Command Finder can be a very useful tool when you know 
what tool you want to use but are unsure of where to find it.

1.	 Menu → Help → Command Finder OR type in Find a Command 	
	 in the top right of the screen.

For example:

2.	 Type “point” into the Search box and hit Enter.

NX returns results relevant to the search in the same dialog box 		
with a description of each command found, a path to where 			 
each command can be located, and—if a command is 				  
not available in the current application—which application(s) it 		
can be used in. 

Figure 1-3: ▶
Command Finder tools.



ATA Engineering      NX 10

Circuit Card Assembly Tutorial in NX

	 5	 Content subject to change without notice. © 2016 ATA Engineering, Inc.  	 NX is a trademark of Siemens PLM Software, Inc.

3.	 Hovering over the command will show where it is located in the 	
	 menu (if the command is available in the current application).
4.	 Clicking the dropdown menu will give options to add the 		
	 command to different toolbars. This feature can be used to add 	
	 shortcuts that are not on the default toolbar.
5.	 Clicking Start Command will start the command. This can also 	
	 be done by simply clicking on the result without going through 	
	 the dropdown list.
6.	 Clicking Help will bring up the NX Help document in your 		
	 browser, allowing you to get more information on the 		
	 particular command.
7.	 Close the Command Finder dialog box.

1.6.	 Know the Assembly Navigator

The assembly navigator shows every part that has been added to 
the assembly, including multiple occurrences of the same part. You 
can show or hide any part in the assembly simply by clicking the 
checkbox next to the part’s name. 

For assemblies that contain many components, it may be beneficial 
to combine multiple instances of the same part in the Assembly 
Navigator on a single row by right-clicking in the navigator and 
selecting Pack All.

You can also search for a particular component by name in the 
Assembly Navigator by right-clicking in the navigator and selecting 
Find Selected Components.

Figure 1-4: ▶
Command Finder “Point” search results.
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Figure 1-5 is an example of what the Assembly Navigator will look like 
for this demo.

1.7.	 Save the Individual Parts

1.	 File → Save → Save All
2.	 File → Close → All Parts

2.	 Meshing the Housing Part
2.1.	 Open the Housing Part

1.	 Open housing_proe.prt.

2.	 Application → Simulation → Advanced or File → Start → Advanced 
Simulation

3.	 Resource Bar → Simulation Navigator → Right-click on housing_proe.
prt and select New FEM…

4.	 The default name appends _fem1 to the part file and uses the same 
location as its parent. For this demonstration, these defaults are 
acceptable.

Figure 1-5: ▶
Assembly Navigator: unpacked (left) and 
packed (right).
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5.	 Click OK.

6.	 Make sure Create Idealized Part is checked.

7.	 Under CAD Part – Bodies, Bodies to Use is set to All Visible by default. 
The dropdown list also shows All, Select, and None. All Visible 
accepts all bodies that are not suppressed in the model. In this 
part (and all others in this demonstration), there is only one body 
that has been imported from the part model and it is by default not 
suppressed, so All Visible is acceptable to use.

8.	 Click OK.

2.2.	 Assign a Material to the Part

1.	 Menu → Tools → Materials → Assign Materials or Home → Properties → 
Assign Materials

2.	 Select the housing body.

3.	 Select Aluminum 6061 from the list of Library Materials.

4.	 Click OK.

Figure 2-1: ▶
New FEM dialog box.
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You can also build your own local library which can be easily reused 
across models if needed. You can create a new material from scratch or 
you can export an existing material in the NX material library and edit 
individual properties. If you want to export an existing material, begin at 
step 5 below.

1.	 Menu → Tools → Materials → Manage Materials

2.	 Click Create Material under Material List – New Material.

3.	 Edit the name and properties to what is desired and click OK.

4.	 Close the Manage Materials dialog box.

5.	 Menu → Tools → Materials → Manage Library Materials

6.	 Set Type to Export Material to Library.

7.	 Set Target Material Library to Single MatML File and enter the path 
where you would like the material library to be located, followed by 
the name you would like the file to have.

8.	 Set Source Material List to Local Materials and select the newly 
created material from the list if you created a new material. If you 
are exporting an existing material, set Source Material List to Library 
Materials and check the box for NX Material Library. Select the 
material from the list that you would like to export.

9.	 Click OK.

This custom material can now be reused across models by loading the 
MatML Library into the material list in that session. If you would like to 
edit a material that has been exported to a user library, continue with the 
following steps.

1.	 Menu → Tools → Materials → Manage Library Materials

2.	 Set Type to Edit Library Material.

3.	 Check Library Material List – User MatML Library and browse to the 
.xml file created in the above steps.

4.	 The material should now appear in the Materials list in the window. 
Select it and click OK.

5.	 In the Isotropic Material dialog box, change any properties as desired 
and click OK.

2.3.	 Promote the Idealized Part

1.	 In the Simulation Navigator under Simulation File View, double-click 
on housing_proe_fem1_i.

2.	 Click OK on the Idealized Part Warning.
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This is the idealized part that will be used to manipulate the geometry 
to simplify the model and make it easier to mesh. Before you can modify 
the geometry, any parts that are going to be changed must either be 
promoted or WAVE linked. 

3.	 Home → Start → Promote.

4.	 Select the housing body.

5.	 Click OK.

Promoting or WAVE linking geometry of the idealized part creates an 
associative link between the idealized part and the original part. This 
provides an editable linked copy of the original part without affecting 
the original part, meaning that any changes made to the geometry of the 
idealized part will not change the geometry of the original part. However, 
updates of the original geometry will be reflected in the idealized part.

2.4.	 Tetrahedral Mesh the Part As Is

Before making any changes to the idealized part, we will see how the 
mesher deals with the small holes and fillets in the original geometry and 
how to make quick changes in the FEM.

1.	 In the Simulation Navigator under Simulation File View, double-click 
on housing_proe_fem1.

2.	 Home → Mesh →  3D Tetrahedral Mesh

Figure 2-2: ▶
Promote Body dialog box.
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3.	 Select the housing body.

4.	 Set the Mesh Parameters – Element Size as 0.2 in.

5.	 Click OK.

6.	 In the Simulation Navigator, click the checkmark next to Polygon 
Geometry to hide the geometry and view just the mesh.

7.	 Home → Checks and Information → Element Quality

8.	 Expanding the dropdown list shows a number of checks that NX can 
perform on the model. Under Output Settings, change Report to 
Failed and Warning.

9.	 Select the mesh and click Check Elements.

Figure 2-3: ▶
3D Tetrahedral Mesh dialog box.

Figure 2-4: ▶
Model Check dialog box.
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As can be seen in Figure 2-6, the element shape check should have 
returned that no bad elements were generated among the 7706 elements 
checked. Now we will generate a coarser mesh, i.e., one with fewer 
elements.

1.	 In the Simulation Navigator, expand 3D Collectors to view the mesh 
collector and the actual mesh.

2.	 Double-click 3d_mesh(1).

3.	 Change the Element Size to 0.6 in.

4.	 Click OK.

Figure 2-6: ▶
Results of the element shape check, 0.2 in.

Figure 2-5: ▶
Housing tetrahedral mesh, 0.2 in.
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5.	 Home → Checks and Information → Element Quality

6.	 Select the mesh and click Check Elements.

As can be seen in Figure 2-8, the element shape check again returns that 
no bad elements were generated. This mesh contains roughly a quarter 
of the elements of the previous mesh. Although no elements failed the 
check, this coarse mesh is not suitable to analyze the model due to the 
shape and number of elements in what would be the high-stress areas.

7.	 Undo the coarse mesh by pressing Ctrl + Z.

Figure 2-7: ▶
Housing tetrahedral mesh, 0.6 in.

Figure 2-8: ▶
Results of the element shape check, 0.6 in.
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2.5.	 How NX Surface Coats the Volume

In NX, solid mesh quality can be controlled if desired by surface meshing 
or by using mesh controls. Surface meshes can be toggled so they will 
not be used for export to the solver, just for meshing technique. It is also 
possible to quickly create a mesh with fewer elements by glossing over 
unimportant details in the geometry by using model cleanup tools on the 
FEM rather than doing this with the design geometry or the idealized part.

1.	 In the Simulation Navigator, hide the tetrahedral mesh and show the 
polygon geometry.

2.	 Home → Polygon Geometry → Merge Face

3.	 Select the horizontal curves that run along the vertical walls of the 
open slots on the outside of the part as shown in Figure 2-9.

4.	 Click OK.

5.	 In the Simulation Navigator, show the tetrahedral mesh by clicking 
the checkbox next to 3D Collectors.

6.	 Home → Context → Update

7.	 Running an element quality check will show that around 175 
elements were eliminated by using the Merge Face command on 
those sets of curves. This is a quick and easy way to reduce the 
number of elements but may result in unfavorable meshes around 
fillets, curves, and holes.

8.	 In the Simulation Navigator, right-click the Solid(1) mesh collector 
under 3D Collectors and select Delete.

9.	 In the Simulation Navigator, right-click housing.prt.1 (1) under 
Polygon Geometry and select Recreate and Update to return the 
model to its original geometry.

Figure 2-9: ▶
Merge face selected curves.
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2.6.	 Sketch Circles at the Six Top Bolt Holes

This is done to be sure to have local areas to connect the model with rigid 
elements easily.

1.	 In the Simulation Navigator under Simulation File View, double-click 
on housing_proe_fem1_i.

2.	 Menu → Insert → Sketch in Task Environment…

3.	 Select the top face, shown in Figure 2-10, as the sketch plane. Click 
OK.

4.	 Home → Curve → Circle

5.	 Create six circles using the centers of the bolt holes on the same 
plane as the sketch as the circle centers. Each circle will have a 
diameter of 0.31 in.

6.	 Sketch → Finish

Figure 2-10: ▶
Top face as the sketch plane.



ATA Engineering      NX 10

Circuit Card Assembly Tutorial in NX

	 15	 Content subject to change without notice. © 2016 ATA Engineering, Inc.  	 NX is a trademark of Siemens PLM Software, Inc.

2.7.	 Use Idealize Geometry to Remove Extraneous Features

1.	 Home → Geometry Preparation → Idealize Geometry

2.	 Select the housing body.

3.	 Remove the small holes and fillets by checking the appropriate 
boxes and entering the above diameter and radius values.

4.	 Click OK.

Your part should look like the one in Figure 2-12. 

Figure 2-11: ▶
Idealize Geometry dialog box.

Figure 2-12: ▶
Housing part after idealization.
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2.8.	 Divide the Top Face

1.	 Home → Geometry Preparation → Divide Face

2.	 Select the top face of the housing body as the Faces to Divide and 
the six circles sketched earlier as the Dividing Objects.

3.	 Click OK.

2.9.	 Split the Housing Body

1.	 Home → Geometry Preparation → Split Body

2.	 Select the housing body as the Target.

3.	 Select New Plane from the dropdown list for Tool - Tool Option and 
specify the orange face in Figure 2-13 as the tool plane.

4.	 Make sure Simulation Settings - Create Mesh Mating Conditions is 
checked and click OK.

2.10.  Generate Connection Elements for the Bolted Joints

1.	 In the Simulation Navigator under Simulation File View, double-click 
on housing_proe_fem1.

2.	 Home → Connections → 1D Connection

3.	 Set Type to Point to Face.

4.	 Select the center point of one of the circles created in section 2.6 as 
the Source and the face enclosed by the circle as the Target.

5.	 Set Connection Element – Element Properties – Type to RBE2.

6.	 Click Apply.

7.	 Repeat until each of the six center points are connected to the 
housing. Uncheck Connection Element – Destination Collector – 
Automatic Creation after creating the first connection elements so 
that all the connections are stored in the same mesh collector.

Figure 2-13: ▶
Splitting the housing body.
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8.	 Repeat this process also for the four through-holes on the lower 
body of the housing. Choose the center point of the circle defining 
each hole on the bottom face of the housing part as the Source and 
the inner wall of the hole as the Target.

2.11.  Mesh the Upper Housing Body

Swept meshing, often referred to as brick meshing, is more powerful 
than just extruding plate elements (as it is associative to the geometry for 
boundary conditions, follows the shape of the side faces, updates with 
geometry updates, etc.).

1.	 Hide the lower body of the housing that was made in step 2.9. This 
can be done by setting the selection filter to Polygon Body, selecting 
the lower body, and pressing Ctrl-B.

2.	 Home → Mesh → 3D Swept Mesh

3.	 Set Type to Until Target.

4.	 Select the eight faces shown in orange in Figure 2-15 as the Source 
Faces. 

Figure 2-14: ▶
Through-hole connection recipe.

Figure 2-15: ▶
Swept meshing the upper body.
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5.	 For the Target Face, select the bottom face. 

6.	 Make sure Element Properties – Type is set to CHEXA(8).

7.	 Enter 0.1 in. for Source Mesh Parameters – Source Element Size.

8.	 Make sure Source Mesh Parameters – Attempt Free Mapped Meshing 
is unchecked and Attempt Quad Only is set to Off – Allow Triangles.

9.	 Make sure Wall Mesh Parameters – Edge Mapping and Target Mesh 
Parameters – Smooth Nodes are also both unchecked.

10.	 Click OK.

2.12.  Fix the Upper Housing Mesh

Looking at either of the bosses in the middle of the upper body, you can 
notice little slivers from the divided face where the boss meets the wall 
(shown in Figure 2-16). These small slivers create problems with the mesh, 
so it is desirable to remove them.

1.	 Polygon Geometry → Collapse Edge

2.	 Select a point on the line of each sliver where the wall meets the 
boss 	for all four instances.

3.	 Click OK.

4.	 Advanced Simulation → Update Finite Element Model

Figure 2-16: ▶
Middle boss slivers.
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2.13.  Mesh the Lower Housing Body

1.	 Hide the mesh and upper body of the housing, and show the lower 	
body.

2.	 Home → Mesh → 3D Swept Mesh

3.	 Select the four faces on the orange plane shown in Figure 2-18 below 	
as the Source Faces.

4.	 Select the bottom face of the lower body as the Target Face.

5.	 Make sure Element Properties – Type is set to CHEXA(8).

6.	 Enter 0.075 in. for Mesh Parameters – Element Size.

7.	 Make sure Source Mesh Parameters – Attempt Free Mapped Meshing 
is unchecked and Attempt Quad Only is set to Off – Allow Triangles.

8.	 Make sure Wall Mesh Parameters – Edge Mapping and Target Mesh 
Parameters – Smooth Nodes are also both unchecked.

Figure 2-17: ▶
Slivers removed after collapsing the edge.

Figure 2-18: ▶
Swept meshing the lower body.
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9.	 Uncheck Destination Collector – Automatic Creation.

10.	 Click OK.

11.	 Save the housing FEM file.

3.	 Meshing the Bracket
3.1.	 Open the Bracket Part

1.	 Open bracket_proe.prt.

2.	 NX should still be in Advanced Simulation mode; if it is not, enter 
Advanced Simulation mode now.

3.	 In the Simulation Navigator, right-click on bracket_proe.prt and 
select New FEM…

4.	 Click OK.

5.	 Make sure Create Idealized Part is checked and Bodies to Use is set to 
All Visible and click OK.

3.2.	 Assign a Material to the Mesh

1.	 Properties → Mesh Collector

Figure 2-19: ▶
Final meshed housing.
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2.	 Select 2D for Element Topology – Element Family.

3.	 Select ThinShell for Element Topology – Collector Type.

4.	 Make sure Properties – Type is set as PSHELL.

5.	 Click Create Physical… on the Properties – Shell Property line.

Figure 3-1: ▶
Mesh Collector dialog box.

Figure 3-2: ▶
Physical Shell Properties dialog box.
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6.	 Click Choose Material on the Properties – Materials – Material 1 line.

7.	 Choose Aluminum_6061 from the list and click OK.

8.	 Enter 0.094 in. for Properties – Default Thickness.

9.	 Click OK on both windows.

3.3.	 Generate the Midsurface

1.	 In the Simulation Navigator under Simulation File View, double-click 
on bracket_proe_fem1_i.

2.	 Advanced Simulation → WAVE Geometry Linker.

3.	 Set Type to Body and select the bracket part.

4.	 Click OK.

5.	 Geometry Preparation → Midsurface by Face Pairs.

Figure 3-3: ▶
Midsurface dialog box.
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6.	 Select the bracket as the Solid Body.

7.	 With Face Pairing - Strategy set to Progressive, click the Automatically 
Create Face Pairs button.

8.	 Make sure Hide Solid Body Upon Apply is checked and click OK.

3.4.	 Generate Circular Imprints Around Bolt Holes

1.	 In the Simulation Navigator under Simulation File View, double-click 
on bracket_proe_fem1.

2.	 Polygon Geometry → More → Circular Imprint

Figure 3-4: ▶
The midsurfaced bracket.

Figure 3-5: ▶
Circular Imprint dialog box.
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3.	 With just the midsurface shown, select the highlighted faces in Figure 
3-6 for Surfaces to Imprint – Select Surface and select the center 
point of each of the holes on the highlighted surfaces for Surfaces to 
Imprint – Select Point or Edge.

4.	 Enter 0.42 in. for the absolute diameter of the circular imprint.

5.	 Click OK.

3.5.	 Generate Connection Element Definitions

1.	 In the Simulation Navigator, expand Polygon Geometry and show the 
original geometry by clicking the checkbox corresponding to bracket.
prt.4.

2.	 Utilities → Point

3.	 With the original geometry shown, create a point at the center point 
of the highlighted holes on the inner side of the part as shown in 
Figure 3-7.

Figure 3-6: ▶
Surfaces to circular imprint.

Figure 3-7: ▶
Point creation guide.
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4.	 Hide the original geometry so just the midsurface is visible.

5.	 Connections → 1D Connection

6.	 With Type set to Point to Face, select one of the points just created 
on the horizontal surface as the Source and the face of the 
corresponding circular imprint as the Target.

7.	 Set Connection Element – Element Properties – Type to RBE2 and 
click Apply.

8.	 Uncheck the Automatic Creation box and create the three remaining 
connection elements on the horizontal plate.

9.	 Change Type to Point to Edge.

10.	 Select one of the six remaining points just created as the Source and 
the edge of the corresponding hole as the Target. Click Apply.

11.	 Create the five remaining connection elements to be used to attach 
the D-connectors to the bracket.

Because a mesh has not been created for the bracket yet, the connections 
just created exist as temporary recipes. Once a mesh is created, these 
recipes will automatically create connection elements between the 
source points and the nodes on the respective face/edge.

3.6.	 Create Mesh Controls

Sometimes to create a better mesh, it is desirable to control how 
elements are created in certain areas of a part, typically holes and fillets. 
For the bracket, we will define how many elements are to be created 
around all of the holes, the circular imprints, and the fillets on the 
horizontal face.

1.	 Mesh → Mesh Control

2.	 Set Density Types to Number on Edge.

3.	 Select the faces between holes and their circular imprints as shown 
in Figure 3-8 as the Targets. There should be ten selections.

Figure 3-8: ▶
Mesh control selections, 1.
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4.	 Set Number on Edge – Number of Elements to 8.

5.	 Click Apply.

6.	 Select the edges of the six small holes on the vertical faces and the 
four corner fillets on the horizontal face as shown in Figure 3-9 as the 
Targets. There should be ten selections.

7.	 Set Number on Edge – Number of Elements to 6.

8.	 Click OK.

3.7.	 Generate the Shell Mesh

To create an optimal mesh, the bracket will be meshed in three sections 
which have been divided by color in Figure 3-10. It is important to mesh 
the sections in the following order: green → red→ blue. The order is 
important because the second and third meshes are seeded, i.e., their 
boundary nodes are defined, by the previous meshes.

Figure 3-9: ▶
Mesh control selections, 2.

Figure 3-10: ▶
Separations for meshing the brackets.
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1.	 Mesh → 2D Mesh

For each section, the properties of the mesh should be the same as seen 
in Figure 3-11. The only exception is that the Mesh Parameters – Meshing 
Method will be set to Subdivision for the green and blue sections while it 
will be set to Paver for the red section. 

2.	 Select the six faces of the green section in Figure 3-10 as the Objects 
to Mesh with the properties set to match those in Figure 3-11. Click 
Apply.

Figure 3-11: ▶
Bracket mesh properties.
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3.	 Select the ten faces of the red section in Figure 3-10 as the Objects 
to Mesh, changing Mesh Parameters – Meshing Method to Paver and 
keeping all the other properties the same. Click Apply.

4.	 Select the three faces of the blue section in Figure 3-10 as the Objects 
to Mesh, changing Mesh Parameters – Meshing Method back to 
Subdivision and keeping all the other properties the same. Click OK.

3.8.	 Turn On Shell Element Thickness Display

1.	 In the Simulation Navigator, right-click on the mesh collector 
containing the three sectioned meshes.

2.	 Click Edit Display.

3.	 Check the box corresponding to Display 2D Element Thickness and 
Offset.

4.	 Click OK.

5.	 Save the bracket FEM file.

Figure 3-12: ▶
2D meshed bracket.

Figure 3-13: ▶
Final meshed bracket.
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4.	 Meshing the D-Connector

4.1.	 Open the D-Connector Part

1.	 Open d_connector_proe.prt.

2.	 NX should still be in Advanced Simulation mode; if it is not, enter 
Advanced Simulation mode now.

3.	 In the Simulation Navigator, right-click on d_connector_proe.prt and 
select New FEM…

4.	 Click OK.

For the D-connector, an idealized part is not needed because no 
modifications will be made to the geometry. Instead, the D-connector will 
be modeled as a concentrated mass with rigid body elements connecting 
it to the bolt locations.

5.	 Uncheck Create Idealized Part and make sure Bodies to Use is set to 
All Visible and click OK.

4.2.	 Assign a Material to the Part

1.	 Properties → Assign Materials

2.	 Select the D-connector body.

3.	 Select AISI_Steel_1005 from the list of Library Materials.

4.	 Click OK.

4.3.	 Compute Mass Properties for the Part

1.	 Menu → Analysis → Measure Bodies…

2.	 Select the D-connector body.

3.	 Check the box corresponding to Results Display – Show Information 
Window

Figure 4-1: ▶
D-connector.
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4.	 We are interested in the mass and centroid of the part as well as the 
moments and products of inertia, which are shown in Figure 4-2. It 
is easiest to leave this information window open for the next steps, 
allowing you to copy and paste values from the window.

4.4.	 Generate a Point at the CG

1.	 Utilities → Point

Figure 4-2: ▶
D-connector mass properties.

Figure 4-3: ▶
Create point dialog box.
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2.	 Enter the X, Y, and Z coordinates of the centroid into the appropriate 
boxes and click OK.

4.5.	 Generate a Concentrated Mass Element at the CG

1.	 In the Simulation Navigator, uncheck the box corresponding to 
Polygon Geometry to view the point just created.

2.	 Mesh → More → 0D Mesh

3.	 Select the point created at the centroid as the Objects to Mesh.

4.	 Select CONM2 for Element Properties – Type. Click the Edit Mesh 
Associated Data button in the same section of the dialog box.

5.	 Input the mass, mass moments of inertia, and mass products of 
inertia found in section 4.3 in the appropriate boxes. Click OK.

6.	 Click OK to create the 0D Mesh.

4.6.	 Generate a Connection Element Definition

1.	 Connections → 1D Connection

2.	 Change Type to Point to Point from the dropdown list.

3.	 Select the point created at the centroid in section 4.4 as the Source.

4.	 Select the arc-centers shown in Figure 4-5 as the Target.

5.	 Make sure Connection Element – Element Properties – Type is set to 
RBE2 and click OK.

Figure 4-4: ▶
1D Connection.
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6.	  Save the connector FEM file.

Figure 4-5: ▶
Arc-center locations.
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