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Overview

This whitepaper gives a broad introduction to how 
users can update their Siemens PLM software and 
licenses. It begins with an overview of requesting 
and maintaining WebKeys and continues with 
discussions on how to view documentation, 
download the latest product releases, and register 
for mailing lists through Siemens GTAC. It also 
describes different license types, explains how to 
download and implement new license files, and 
shares methods for borrowing licenses to work 
offline.

As always, ATA is standing by to answer any of your 
questions, help solve your licensing problems, and 
identify ideal license configurations to meet your 
team’s requirements. 

Software:
Femap
NX
Simcenter 3D

This whitepaper is part of a series of free Siemens 
PLM Software training resources provided by ATA. 
For more whitepapers, tutorials, videos, and 
macros, visit ATA’s PLM Software website: 
http://www.ata-plmsoftware.com/resources.
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1.	 WebKey Account Management

WebKey accounts provide personal, single-point authentication for Siemens 
PLM Software, giving users access to the product information and support tools 
located at www.siemens.com/gtac. These resources include the following:

•	 Software downloads and patches

•	 License file retrieval and emergency license requests

•	 Product-specific documentation, notes, and guides

•	 Solution Center database of problem solutions

•	 Web support for incident reporting and tracking*

•	 WebKey account management

*As a value-added reseller for Siemens PLM Software, ATA Engineering is proud 
to be the first line of support for our customers’ questions and problems. ATA 
hosts a technical support hotline with unmatched expertise Monday through 
Friday from 5:00 AM to 5:00 PM Pacific. Contact the hotline by phone at 877-ATA-
4CAE (877-282-4223) or through our web interface. ATA can help expedite 
Siemens GTAC support when necessary.

WebKey account management is available at the following link, which can also 
be found on the top-level GTAC page:

https://www2.industrysoftware.automation.siemens.com/webkey/

Here, users can request WebKey accounts, change passwords, recover forgotten 
usernames and passwords, add Sold-to IDs, and update account information.

1.1. 	 Request a WebKey

Active customers can request a WebKey account at the following link, which can 
also be reached by selecting “Create Account” on the top-level WebKey account 
management page. Users can select between standard and Femap-specific 
request forms:

https://www2.industrysoftware.automation.siemens.com/webkey/
chooseProductLine.jsp

You will need your Sold-to ID, which can be found directly under the Sold-
to information on the shipping order or in the upper left-hand corner of the 
license file. Note that Femap users should omit the five leading zeros. Additional 
information depends on the associated product set:

•	 Femap users with a dongle will need to supply a portion of the serial 
number, which is printed on the dongle itself or is available in Femap 
from the Help → About menu. For the example serial number “900-FX-NT-
1234567F,” users should enter “FX-NT-1234.”

http://www.siemens.com/gtac
http://www.ata-plmsoftware.com/support/
https://www2.industrysoftware.automation.siemens.com/webkey/
https://www2.industrysoftware.automation.siemens.com/webkey/chooseProductLine.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/chooseProductLine.jsp
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•	 Femap users with floating licenses should supply the LMHost ID.

•	 Other users (NX, Simcenter 3D, Simcenter Nastran, and Solid Edge) should 
supply a WebKey Access Code (WAC), which can be found on the upper-
right corner of the license file.

After completing the form, you will receive an email with a link to activate the 
WebKey. The link is valid for thirty days, and the account will be available for use 
as soon as it is activated.
  

1.2.	 Change WebKey Password

To update your WebKey password, use the following link, which can also be 
reached by selecting “Change Password” at the top-level WebKey account 
management page:

https://www2.industrysoftware.automation.siemens.com/webkey/
password.jsp

  

1.3.	 Recover WebKey Username and Password

To have your username sent to the associated email address, select “Forgot your 
Username” on the top-level WebKey account management page, or follow the 
link below:

https://www2.industrysoftware.automation.siemens.com/webkey/
forgotUsername.jsp

You can also reset forgotten passwords, at which point you will receive an email 
with a new automatically generated password. This option can be reached by 
selecting “Forgot your Password” on the top-level WebKey account management 
page, or by following the link below:

https://www2.industrysoftware.automation.siemens.com/webkey/
forgotPassword.jsp  
  

1.4.	 Add Sold-To/Install

You can add a new Sold-to or Install to your account with the following link, 
which can also be reached by selecting “Add a SoldTo/Install” on the top-level 
WebKey account management page.

https://www2.industrysoftware.automation.siemens.com/webkey/
addSoldTo.jsp  

1.5.	 Update Account Information

You can update your WebKey account information, including name and phone 
number, using the link below or by selecting “Update Account” on the top-level 
WebKey account management page.

https://www2.industrysoftware.automation.siemens.com/webkey/
update.jsp

https://www2.industrysoftware.automation.siemens.com/webkey/password.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/password.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/forgotUsername.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/forgotUsername.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/forgotPassword.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/forgotPassword.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/addSoldTo.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/addSoldTo.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/update.jsp
https://www2.industrysoftware.automation.siemens.com/webkey/update.jsp
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2.	 Product Updates and Documentation 

Users with a valid WebKey can quickly access new product downloads from 
the GTAC website. In addition, GTAC hosts a documentation repository and 
maintains email lists that highlight product releases and solution center articles.

2.1.	 Downloading New Products

New product releases and maintenance patches can be accessed at the link 
below, or by navigating to the main GTAC page and selecting “Download or 
Upload Files.”

https://download.industrysoftware.automation.siemens.com/

After logging in with a valid WebKey, select from the available products on the left 
side of the screen. The available subfolders vary based on the product chosen 
but generally have a logical structure and allow for the download of full product 
releases, maintenance patches, and addition add-ons as applicable. README.
txt files are commonly used to identify files and outline basic download and 
installation instructions.

The most recent Femap releases and prior versions are available at Femap → 
Full Products, VXX.X.X. The most recent NX release is available at NX → NX XXXX 
Series → NX XXXX with prior supported and unsupported releases available at NX 
Support → NX Supported and NX Support → NX End of Standard Maintenance, 
respectively. 

Note that some NX releases are split between three smaller files with extensions 
.zip, .z01, and .z02. To install these versions, download all of the smaller files and 
then use WinZip or 7-Zip to extract only the .zip file, which will automatically 
unzip and merge all three files.

Some maintenance updates are available as smaller files that upgrade the 
existing software installation. Alternatively, a full, clean installation of the newer 
version can be completed.

2.1.1.	 Continuous Release for NX and Simcenter 3D

NX and Simcenter 3D moved to a Continuous Release update methodology 
beginning with the January 2019 release of NX (Version 1847) and Simcenter 
3D 2019.1. With this release cadence, functional enhancement releases will be 
delivered every six months, with monthly updates providing fixes. There are no 
schema- or compatibility-related changes in monthly updates.

https://download.industrysoftware.automation.siemens.com/
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Installation files are provided in two formats:

•	 MSI format is a complete installation that is available as a downloadable 
.zip file or on the DVD media. This version is designed to update existing NX 
installations or allow the standard base installation of NX.

•	 MSP format is an upgrade-only patch installer that will upgrade your 
previous NX version to the current version and is only available as an .msp 
file download. This option is recommended for customers who are looking 
to update a recent version of NX.

To return to a previous version of NX, it is recommended that you uninstall the 
newer version using Add/Remove Programs before using the original media to 
install the previous version.

Instructions for parallel installation of continuous release versions can be found 
in the installation guide located inside the install package at docs\nx_install_wnt.
pdf.

2.1.2.	 Automatic Updates for NX and Simcenter 3D

January 2019’s release of NX and Simcenter 3D 2019.1 also introduces optional 
automatic updates for these products. This feature is turned off by default and 
can be controlled under customer defaults at Gateway → General → Software 
Update, where users can choose between Notify or Notify and Download. 
The latter option will automatically download and install the latest version of 
software each month as it becomes available. As shown in Figure 2-1, new icon 
in the upper right-hand corner shows the status of automatic update, with green 
indicating that the product is up to date, red indicating that the product is out 
of date, yellow indicating that a new version is available to download, and blue 
indicating that the new version is actively downloading. The icon will be grey if 
automatic update is turned off.

Figure 2-1: ▶ 
A new icon indicates the current status of 
automatic update.
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2.2.	 Accessing Product Documentation

Product documentation can be accessed at the link below, or by navigating to 
the main GTAC page and selecting “Documentation.”

https://support.industrysoftware.automation.siemens.com/general/
documentation.shtml

Customers can select their desired product from the list and then choose 
among current and previous software versions. Available resources include 
user manuals, reference guides, release notes, and more. The documentation is 
public for some products, including NX and Simcenter 3D, but other software like 
Femap requires a WebKey login. 

2.3.	 Alerts for Product Updates and Support Articles

There are four email distribution lists available to help users stay up to date on 
product releases, fixes, Solution Center FAQs, and technical newsletter articles. 
Basic descriptions, subscribe and unsubscribe instructions, and options for 
filtering are described in the following sections. Content from these sources can 
also be accessed by searching in the Solution Center database:

https://solutions.industrysoftware.automation.siemens.com/index.php

2.3.1.	 Software Field Bulletin (SFB) Mailing List

Messages to this list notify users about new product releases, fixes, and end 
of standard maintenance schedules. You can subscribe to the SFBmail list by 
sending a blank message to:

sfbmail-subscribe.plm@siemens.com

You will receive a welcome email with your initial password and a link to the 
subscription page. This page provides the option to filter by product, to turn 
digest mode on or off, and to change your login password:

http://mailman.industrysoftware.automation.siemens.com/mailman/
options/sfbmail

You can remove yourself from the SFBmail list from the options page or by 
sending a blank message to:

sfbmail-unsubscribe.plm@siemens.com

You will receive a confirmation email and must send a reply to that message or 
click the confirmation link to approve the unsubscribe request.

2.3.2.	 GTAC Newsletter Mailing List

Messages from this list include links to all new technical newsletter articles 
submitted in the past month by the GTAC global support staff. You can subscribe 
to the newsletter list by sending a blank message to:

newsletter-subscribe.plm@siemens.com

https://support.industrysoftware.automation.siemens.com/general/documentation.shtml
https://support.industrysoftware.automation.siemens.com/general/documentation.shtml
https://solutions.industrysoftware.automation.siemens.com/index.php
mailto:sfbmail-subscribe.plm%40siemens.com?subject=
http://mailman.industrysoftware.automation.siemens.com/mailman/options/sfbmail
http://mailman.industrysoftware.automation.siemens.com/mailman/options/sfbmail
mailto:sfbmail-unsubscribe.plm%40siemens.com?subject=
mailto:newsletter-subscribe.plm%40siemens.com?subject=
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You will receive a welcome email with your initial password and a link to the 
subscription page. This page provides the option to filter by product, to turn 
digest mode on or off, and to change your login password:

https://mailman.industrysoftware.automation.siemens.com/mailman/
options/newsletter

You can remove yourself from the newsletter list from the options page or by 
sending a blank message to:

newsletter-unsubscribe.plm@siemens.com

You will receive a confirmation email and must send a reply to that message or 
click the confirmation link to approve the unsubscribe request.

2.3.3.	 Solution Center Symptom Solution Articles

You can subscribe to the Solution Center list by sending a blank message to:

solutioncenter-subscribe.plm@siemens.com

You will receive a welcome email with your initial password and a link to the 
subscription page. This page provides the option to filter by product, to turn 
digest mode on or off, and to change your login password:

http://mailman.industrysoftware.automation.siemens.com/mailman/
options/solutioncenter

You can remove yourself from the Solution Center list from the options page or 
by sending a blank message to:

solutioncenter-unsubscribe.plm@siemens.com

You will receive a confirmation email and must send a reply to that message or 
click the confirmation link to approve the unsubscribe request.

2.3.4.	 Weekly Summary List

This list offers a weekly summary of new articles and SFBs. You can subscribe to 
the summary list by sending a blank message to:

summary-subscribe.plm@siemens.com

You will receive a welcome email with your initial password and a link to the 
subscription page. This page allows you to enable or disable mail delivery and to 
change your password:

http://mailman.industrysoftware.automation.siemens.com/mailman/
options/summary

You can remove yourself from the summary list from the options page or by 
sending a blank message to:

summary-unsubscribe.plm@siemens.com

You will receive a confirmation email and must send a reply to that message or 
click the confirmation link to approve the unsubscribe request.

https://mailman.industrysoftware.automation.siemens.com/mailman/options/newsletter
https://mailman.industrysoftware.automation.siemens.com/mailman/options/newsletter
mailto:newsletter-unsubscribe.plm%40siemens.com?subject=
mailto:solutioncenter-subscribe.plm%40siemens.com?subject=
http://mailman.industrysoftware.automation.siemens.com/mailman/options/solutioncenter
http://mailman.industrysoftware.automation.siemens.com/mailman/options/solutioncenter
mailto:solutioncenter-unsubscribe.plm%40siemens.com?subject=
mailto:summary-subscribe.plm%40siemens.com?subject=
http://mailman.industrysoftware.automation.siemens.com/mailman/options/summary
http://mailman.industrysoftware.automation.siemens.com/mailman/options/summary
mailto:summary-unsubscribe.plm%40siemens.com?subject=
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3.	 Licensing Options

Licenses are generally configured for network or node-locked use and can be 
issued on a perpetual or subscription basis. ATA is happy to help you consider 
which license and configuration options are best suited to your current and long-
term situation.

3.1.	 Floating vs. Node-Locked

Software licenses can be categorized as either floating or node-locked 
depending on where they can be used:

•	 Floating licenses are typically more expensive, but they allow anyone 
on the network to use the licensed product, up to the number of users 
specified in the license file. 

•	 Node-locked licenses limit software usage to an individual node. NX 
and Simcenter 3D typically tie a node-locked license to an individual 
computer’s MAC address. Femap typically ties node-locked licenses to 
a USB dongle, which can be transferred between computers. Note that 
Femap, NX, and Simcenter 3D cannot be accessed through a remote 
desktop application when a node-locked license is used.

License files can contain a mix of node-locked and floating licenses, with the 
node-locked features available on the specified machines and the floating 
features available to anyone with network access.

3.1.1.	 Changing License Type in Femap

Femap users can change their licensing method using batch files located in the 
top Femap directory (e.g., C:\Siemens\FEMAPv1201):

•	 go_demo.bat converts your licensing method to the Femap Node-Limited 
Demonstration version.

•	 go_dongle.bat converts your licensing method to use a security key.

•	 go_network.bat converts your licensing method to the floating/network 
configuration.

•	 go_subscription.bat converts your licensing method to the online/
web subscription configuration. Note that unlike the other files, go_
subscription.bat is located inside the subscription subfolder, e.g., C:\
Siemens\FEMAPv1201\subscription.

Simply double-click the batch file to run. Note that Femap and NX Nastran 
should be closed before these tools are run.
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3.1.2.	 Changing License Types in NX and Simcenter 3D

Unlike Femap, batch files are not required to change licensing methods in NX 
or Simcenter 3D. Instead, floating or node-locked licensing is determined by 
whether a license server or license file is specified on the NX_Server registry key 
or the SPLM_LICENSE_SERVER environment variable, with the registry key taking 
precedence. See section 4.3.2 for more details.

3.2.	 Perpetual, Rental, and Subscription Licenses

Software has traditionally been available through either perpetual licenses, 
short-term rentals, or subscriptions:

•	 Perpetual licenses have the highest upfront cost but are by far the lowest-
priced option over the long run. In addition to the initial license cost, users 
typically choose to maximize their investment by paying an annual fee to 
cover maintenance, enhancements, and support (ME&S, or maintenance). 
This allows users to receive regular software updates that provide new 
features and bug fixes and to enjoy continued access to ATA’s technical 
support services. Users who end their maintenance still have access to 
their software, albeit without the ability to upgrade to newer product 
releases.

•	 Rental licenses come with a three-month minimum duration and are only 
cost-effective for finite, short-term periods. This is the most expensive 
option over the long run, although credit toward a perpetual license is 
available for users who decide to purchase after the rental term.

•	 Subscriptions have the lowest entry cost for a twelve-month minimum 
term, but the costs break even with perpetual plus maintenance licenses 
within the first few years. Subscription licenses provide no residual value.

3.3.	 Online Subscription Licenses

Siemens PLM Software products are becoming increasingly available as monthly 
or annual subscriptions through their online store. Available configuration 
options can be limited and vary by product. However, subscription-based 
licensing offers a low entry cost, the ability to quickly scale licenses up or down 
depending on current demand, and the flexibility to pay as you go. 

3.3.1.	 Femap Online Subscriptions

Monthly and annual subscriptions are available for Femap in five popular 
configurations:

•	 Femap stand-alone

•	 Femap with Simcenter Nastran

•	 Femap with Simcenter Nastran and Dynamic Response
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•	 Femap with Simcenter Nastran and Advanced Bundle

•	 Femap with Simcenter Nastran and Advanced Bundle with Desktop 
Extension

The Advanced Bundle offers the Dynamic Response capabilities in addition to 
the functionality previously available in the Aeroelasticity, DMAP, Superelement, 
and Distributed Memory Parallel (DMP) add-on modules. Desktop Extension 
removes checksum control, allowing the user to manually edit input files and run 
the analysis independently of Femap.

Visit ATA’s page on the Siemens PLM web store for pricing and additional 
information.

Femap’s subscription version is identical to the equivalent perpetual version, and 
files can be easily shared between users with different license configurations. 
Femap monthly online subscriptions are node-locked by MAC address.

3.3.2.	 NX Cloud Connected Products

NX Cloud Connected Products are available as monthly or annual subscriptions 
and come in five configurations:

•	 NX Cloud Connected – Core Designer

•	 NX Cloud Connected – Advanced Designer

•	 NX Cloud Connected – Mold Designer

•	 NX Cloud Connected – Scan to Part

•	 NX Cloud Connected – Drafting & Layout

These configurations utilize a local install of software with the license managed in 
the cloud. Core Designer includes solid part modeling and assembly modeling, 
plus sheet-metal design, freeform modeling, and convergent modeling. 
Advanced Designer and Mold Designer add more advanced design tools and 
streamline the entire mold development process, while Scan to Part brings 
powerful reverse engineering tools, and Drafting & Layout offer tools for creating 
engineering drawings and design layouts.

Visit the Siemens PLM web store for additional information and contact ATA with 
any questions.

3.3.3.	 Simcenter on the Cloud

Siemens offers the following simulation solutions through the Rescale platform:

•	 Simcenter 3D

•	 Simcenter Nastran

•	 Simcenter STAR-CCM+

•	 Simcenter Aimsim

http://partnertrack.plm.automation.siemens.com/z/194/9915439/
https://www.dex.siemens.com/plm/nx-cloud-connected-products/
https://www.ata-plmsoftware.com/contact/
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These solutions are available through a web browser interface, and bring-your-
own-license and pay-as-you-go licensing configurations are available. Visit the 
Siemens PLM web store for additional information and contact ATA with any 
questions.

3.4.	 Value-Based Licensing for NX and Simcenter 3D

Value-based (token) licensing for NX CAD and Simcenter 3D allows users to run 
any combination of token-enabled applications, provided enough tokens are 
available. This gives users access to various applications without buying the 
corresponding add-on modules, making it cost-effective for customers who need 
to access a variety of capabilities and offering flexibility to try new capabilities 
and accommodate changes in capability usage over time. Value-based licensing 
can be easily combined with traditional module-based license configurations, 
with module-based licenses being checked out before tokens are used when 
available. Value-based licensing operates using the same Flex license server 
as module-based licenses. Tokens are not consumed; when a user exits NX or 
Simcenter 3D, the tokens are released back to the pool for others to use. Note 
that separate token pools are used for NX CAD and Simcenter 3D applications, 
e.g., NX tokens could not be used to run Simcenter Nastran.

Many NX add-on modules can be licensed through the token pool, including 
Mechatronics Concept Designer (MCD), Advanced Sheet Metal, Molded Part 
Validation, NX Realize Shape, Weld Assistant, Human modeling, Routing, 
translators, and more. A Mach 1 floating license or higher is required as the base 
seat, and after that, each additional application checks out a defined number 
of tokens. NX CAD tokens are only available on a subscription basis and are 
supported for NX 1872 (Summer 2019) and later.  

Most Simcenter 3D and Simcenter Nastran products are available through token 
licensing, including various solver environments, Simcenter Thermal/Flow, 
modeling add-ons, solutions like Simcenter Durability and Response Dynamics, 
Simcenter Motion, and Simcenter Flexible Pipe. A base seat of Simcenter 3D 
is required, and after that, each additional application checks out a defined 
number of tokens. Simcenter 3D tokens can be obtained on a perpetual, rental, 
or subscription basis and are supported for Simcenter 3D v11 and higher.

3.5.	 License File Format

A license file is a text file containing information like server names, host 
identifiers, and licensed features with “\” used as a continuation character. 
SERVER lines identify the node name and host ID of the license server and the 
port number of the license manager daemon. There may be multiple SERVER 
lines for redundant server configurations or no SERVER lines for stand-alone 
node-locked license files. The VENDOR line specifies the name of the vendor 
daemon supported by the license file.

https://www.dex.siemens.com/plm/nx-cloud-connected-products/
https://www.dex.siemens.com/plm/nx-cloud-connected-products/
https://www.ata-plmsoftware.com/contact/
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PACKAGE lines are used to license a product suite to enforce bundles in some 
products and as a more efficient way to distribute a license file with a large 
number of features sharing the same INCREMENT / FEATURE line arguments. 
The PACKAGE line doesn’t license anything by itself but instead requires a 
matching INCREMENT / FEATURE line to license the entire package.

In general, license files should not be edited, with the exception of hostnames 
on the SERVER line(s), port numbers on the SERVER line(s), and user_info on 
INCREMENT / FEATURE line(s). If the hostname is not supplied when a license 
file is requested, a placeholder will be used and should be replaced with the 
real hostname. The proper hostname and port number value are used on the 
client side for setting the server setting to port@hostname. The user_info field in 
an INCREMENT / FEATURE line displays a descriptive name for the bundle and 
should not exceed twenty characters, use special characters such as quotes, or 
contain a continuation character.

3.6.	 Licensing User Guide

For additional details on license formats, configurations, and administration, visit 
the Siemens PLM Licensing User Guide, located on the GTAC Downloads page 
under Siemens PLM Licensing → Product Updates → Documentation.

Figure 3-1: ▶ 
Excerpt from the Siemens PLM Licensing 
User Guide describing the parts of an 
INCREMENT line.
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4.	 License Updates

This section describes how to download and update new license files, which will 
be needed for upgrading software to new major releases.

4.1.	 Downloading New License Files

New license files can be retrieved from the following link, which can also be 
accessed from the main GTAC page by selecting “License Management.”

https://www2.industrysoftware.automation.siemens.com/
LicenseManagement/Application

After logging in via WebKey, select the applicable Sold-To/Install from the 
dropdown selection. Next, select Passwords and License Files, choose the 
product, version, and LM Host or Dongle ID of interest, as applicable, and click 
Continue to generate and download the license file.

In addition to downloading new license files, the License Management menu 
provides options to obtain emergency license files, view a configuration report to 
see license quantities and expirations, and see Composite Host ID information.

4.2.	 Updating Node Locked Licenses

To update the license for a node-locked Femap installation, open Femap and 
navigate to Help → About. Click Security, and enter the two access codes from the 
license file, without any trailing spaces.

To update the license for a node-locked NX or Simcenter 3D installation, save the 
new license file in place of the original license file.

4.3.	 Updating Floating Licenses

After downloading the new license file (see section 4.1), check that the proper 
hostname and port number are specified on the SERVER line, and if they are not, 
update those fields.

In most cases, license updates can be completed by simply stopping the old 
license service, replacing the previous license file with the new license file, and 
starting a new license service. Some updates will require a newer version of the 
FLEXlm license manager tool to be installed.

4.3.1.	 Install and Configure the License Manager

The FLEXlm license manager can be installed from both NX and Femap 
installation packages, or it can be downloaded independently from the GTAC 
downloads site. From an NX package, double-click Launch.exe and then choose 
install license manager. For Femap, double-click setup.exe and, on the Select 
Features page of the install wizard, choose just the Flexlm License Manager.

https://www2.industrysoftware.automation.siemens.com/LicenseManagement/Application
https://www2.industrysoftware.automation.siemens.com/LicenseManagement/Application
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The license manager is configured using the LMTOOLS program, which should 
be available under the NX or Femap start directory (Start → All Programs → Femap 
vXX.XX or Siemens NX), or it can be accessed by running LMTOOLS.exe from the 
installed directory (C:\Siemens\FemapvXXXX or C:\Siemens\NX).

Start on the Config Services tab: enter a Service Name, specify a path to the 
lmgrd.exe file that can be found in the installation directory, specify the path 
to the license file, and check on the Start Server at Power Up and Use Services 
buttons. Save the service before continuing.

The license server must be manually started the first time from the Start/Stop/
Reread tab. Select the service that was previously configured and press the Start 
Server button. The FLEXlm should now be operating normally and is ready to 
distribute licenses on the network. The Server Status tab can be used to verify 
that everything is functioning properly.

4.3.2.	 Direct Femap and NX to the License Server

To point Femap to the license server, open Femap, navigate to Help → About, 
and click security. In the License File field, enter an at sign followed by the name 
of the license server, i.e., “@LicenseServer.” Alternatively, a copy of the license file 
can be placed in the Femap directory, and Femap will extract the name of the 
license server, but this is not the suggested approach because each local copy of 
the license file would need to be replaced when licenses are updated.

NX and Simcenter 3D determine where to look for the license server or license 
file based on the entry in the NX_Server registry key (HKEY_CURRENT_USER 
\ Software \ Siemens_PLM_Software \ Common_Licensing) or the SPLM_
LICENSE_SERVER (as of NX 10.0) or UGS_LICENSE_SERVER environment 

Figure 4-1: ▶ 
Configuration settings for license manager.
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variable. The registry setting will always override any environment variable 
setting, even if it is “blank” or empty. Prior to NX 9.0, the License Options 
utility outside of NX was used to set the environment variable. As of NX 10.0, 
the Licensing Tool (Start → All Programs → Siemens NX → Licensing Tools → 
Licensing Tool) is used to set the registry key, which will take precedence over 
any environment variable. Note that the only way to make the variables effective 
again is to delete the NX_SERVER registry key.

License server information for NX Nastran is specified by the AUTH line in the 
nastran.rcf file, which is located in the conf folder of the NX Nastran installation.
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5.	 Additional License Options

This section covers additional license options such as controlling bundle settings 
for NX and Simcenter 3D and accessing licenses remotely.

5.1.	 NX/Simcenter 3D Bundle Settings

The bundles to be used at launch can be set on the Bundle Settings tab of the 
Siemens PLM Software Licensing Tool, which is available in the NX folder at 
Start → All Programs → Siemens NX → Licensing Tools → Licensing Tool. Bundles 
can also be updated for an individual session of NX by going to File → Utilities → 
Select Bundles. In either case, use the Add and Remove buttons to move bundles 
back and forth between Available Bundles and Applied/Selected Bundles. The 
order of bundle names in Applied Bundles is the order in which the application 
will attempt to check out any feature.

Siemens PLM Licensing uses Automatic Bundle Consolidation to maximize the 
number of licensed modules available for use by attempting to reduce crossover 
licensing. As an example, in a situation where a user has “Mach 1” and “Mach 
3” NX license bundles selected, the “Mach 1” seat will typically be checked out 
when NX is started and basic modeling functions are used. When commands 
from the “Mach 3” bundle are used, the “Mach 3” bundle will be checked out and 
the “Mach 1” bundle will be checked back in. The “Mach 3” bundle will remain 
checked out even after those commands are completed to ensure that the user 
has access to those features again, should they be required. Users could choose 
to relinquish the “Mach 3” bundle and revert back to “Mach 1” without exiting NX 
using this procedure:

1.	 Switch to the Gateway application, available under the File menu, to check 
in all “Mach 3” bundle features except for “gateway” and the bundle itself.

2.	 Go to File → Utilities → Select Bundles. The Licensing Options dialog shows 
the “Mach 3” bundle at the top of the list, because it is the bundle currently 
in use. Select the “Mach 3” (NX13100N) bundle and use the down arrow to 
move it below the “Mach 1” (NX11110) bundle, as shown in Figure 5-1.

3.	 Switch back to the Modeling application. When a modeling command 
is selected, the “Mach 1” bundle will be checked out and the “Mach 3” 
bundle is checked in, making it available to other users on the network.
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In some cases, individual features are available as add-on “sticky” modules, 
which cost less than an individual floating license feature but must be manually 
released from an NX session. Sticky modules aren’t reserved when a bundle is 
initially accessed. Once a sticky module is checked out, it will remain attached 
to the user’s session until the user manually releases it at File → Utilities → Select 
Bundles by highlighting the feature and clicking “Free Selected Licenses,” or until 
the NX session is closed.

5.2.	 Accessing Licenses Remotely

Users working remotely or on travel who use network licensing may be able to 
access their license server using a VPN, which would allow for normal use of the 
software with no additional changes required. When that isn’t an option, License 
Borrowing allows a single seat to be checked out for offline use. The borrow 
feature, indicated by the BORROW keyword on an INCREMENT line in the license 
file, is now enabled by default and no longer requires a special configuration like 
in the past. Note that licenses are borrowed for specific user accounts on specific 
machines; other users on the same computer will not have access to a borrowed 
license.

5.2.1.	 Borrowing a License in NX or Simcenter 3D

Open the Siemens PLM Software Licensing Tool, which is located in the NX folder 
under Start → All Programs → Siemens NX → Licensing Tools → Licensing Tool, and 
go to the Borrowing Settings Tab. Click Borrow, which will open a new window 
that allows specific license features to be checked out and the return date to be 
specified. The Change button allows the return date to be updated, and Return 
can be used to check the borrowed license back in early, provided you are 

Figure 5-1: ▶ 
Licensing Options dialog box.
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connected to the license server. Changes on the Borrowing Settings tab of the 
Licensing Tool, shown in Figure 5-2, do not go into effect until Apply has been 
clicked.

The license pool on the server will be reduced by the number of borrowed 
licenses for the entire duration they are checked out. Licenses can be 
borrowed for up to 120 days (2880 hours). At the return time, the license will be 
automatically returned to the license server, even if the device is still offline.

5.2.2.	 Borrowing a License in Femap

Begin by running the Borrow.exe utility located in the main Femap directory, 
and make sure the correct server is specified in the Server / License field. Select 
the various features you want to borrow, select the required number of days, 
and click Borrow Selected, as shown in Figure 5-3. The chart will update to show 
features that have been checked out, how many are available on the server, and 
when the borrowed licenses expire. Licenses can be returned to the server using 
the same utility.

When you launch Femap with a borrowed license, a pop-up message will 
notify you how many days are left on the license. Borrowed licenses will also be 
reflected on the license page inside Femap at Help → About → Security → Show 
Licenses.

Figure 5-2: ▶ 
Borrowing settings tab of the Siemens PLM 
Software Licensing Tool.
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The license pool on the server will be reduced by the number of borrowed 
licenses for the entire duration they are checked out. Licenses can be 
borrowed for up to 120 days (2880 hours). At the return time, the license will be 
automatically returned to the license server, even if the device is still offline.

Figure 5-3: ▶ 
Femap License Borrowing utility.
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