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What‘s New in 2401 
Simcenter Femap
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What’s new 
Simcenter Femap 2401
Managed Environments
Geometry
Preprocessing
Meshing
Performance Improvements
Analysis and Solver Support
Postprocessing
Miscellaneous and API
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Siemens Xcelerator Share is now Teamcenter Share

To reflect this in the User Interface, the names of 
the following have changed:

• PDM -> Siemens Xcelerator Share menu is now 
PDM -> Teamcenter Share

• Tools -> Toolbars -> Siemens Xcelerator Share is 
now Tools -> Toolbars -> Teamcenter Share

• Siemens Xcelerator Share toolbar is now called 
Teamcenter Share
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“Add Matching Holes” has been added 
to the Pick^ menu of the Standard Entity 
Selection dialog box for curves

Simply select a curve of any hole and 
then use this option to select all other 
holes in the model which have the same 
radius as the selected curve

Helpful when using the Geometry -> 
Surface -> Remove Hole command, 
along with any tool in the Meshing 
Toolbox used for defeaturing geometry 
which contains holes
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Laminates – Layup Builder
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The Layup Builder, a new Dockable Pane, can be used to interactively create any number of 
Layups using an intuitive table control
• Accessed by the Tools -> Layup Builder command



Simcenter Femap 2401
Laminates – Layup Builder
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Unlike the Model -> Laminates -> Layup command used to 
create a new Layup in Femap, the Layup Builder offers 
multiple options to create “Layup Stacks” which can then 
be used to create multiple Layups and Properties at once 
based on selection of Elements, Surfaces, and/or Groups:
• New Layup Stack – Plys are entered into the table control 

using similar workflow to Layup Manager

• Load from Layups – Table control is populated using 
information from an existing Layup in the model

• Attach Composites HDF5 File – Table control is populated 
using information from an external file created by a different 
application, which currently can only come from Fibersim, 
another Siemens DI Software product



Simcenter Femap 2401
Laminates – Layup Builder

Unrestricted | © Siemens 2024 | Siemens Digital Industries SoftwarePage 10

When using Attach Composites HDF5 File, there can be as many as 3 steps during attach process:
1. Select HDF5 (*.h5) file
2. If units are detected in HDF5 file, and certain units do not match setting for “Geometry Scale 

Factor” on Geometry/Model tab in File -> Preferences, user is prompted to scale HDF5 data
3. A preview of the Ply locations is shown in the graphics window and user is prompted to 

examine locations before continuing 



Simcenter Femap 2401
Laminates – Layup Builder
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Once the table control has been populated, various Layup Builder 
Tools are available to update and investigate the Layup Stack
• Save Table – Saves the populated table to the database so it can 

be reloaded then edited

• Reload/Edit Layup Stack – Reloads a saved Layup Stack into the 
Layup Builder

• Delete Layup Stack – Deletes any number of saved Layup Stacks 
from the database

• Copy to Clipboard – Copies contents of Layup Builder to clipboard

• Send to Excel – Sends contents of Layup Builder to Excel



Simcenter Femap 2401
Laminates – Layup Builder
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Layup Builder Tools – All
• Show/Hide Columns – Allows user to select which 

columns are currently being displayed in the table 
control and toggle the AutoFit to Window Width option

• Edit Layup Builder Options – Opens Layup Builder 
Options dialog box which contains two tabs:

• Composites HDF5 Options – Specifies options only 
used during and/or after the population of the table 
control using Attach Composites HDF5 File

• Layup Creation – Specifies options used during 
creation of Layups as well as others used for viewing 
and/or showing items in the graphics window
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Laminates – Layup Builder

Unrestricted | © Siemens 2024 | Siemens Digital Industries SoftwarePage 13

Layup Builder Tools – All
• Add at Top/Add at Bottom/Add Above Selection – Depending on 

selected command, adds new row to the top, bottom, or above the 
selected row in the current Layup Stack

• Add Multiple – Opens Add Multiple Rows dialog box allowing user to 
specify Number of Rows to Add at the top, bottom, or above the 
selected row in the current Layup Stack

• Duplicate – Opens Duplicate Selected Rows dialog box allowing user 
to duplicate selected row(s) by placing them above, below, or above 
the selected row using either matching order or symmetric order

• Delete Selected Plys – Deletes selected row(s) from current Layup 
Stack
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Laminates – Layup Builder
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Layup Builder Tools – All
• Move Up/Move Down – Moves selected row(s) up or down one row at 

time

• Clear All – Clears all contents of the table control

• Check Ply Info – Creates the Errors Column which indicates if each row 
has all required info to properly create a ply in any number of Layups

• To further diagnose why a particular row is not valid, hover the cursor 
over the field in the Errors column for that row and a “Tooltip” with error 
information will be displayed

• Build Layups – Once everything has been specified, this button is used 
to automatically create all required Layups
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Laminates – Layup Builder
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Layup Builder Tools – All 
• Show/Preview Mesh Info – The top section offers options to 

specify how items will be highlighted in the graphics window:
• Show Selected Elements – Highlights all elements which are 

selected in rows currently selected in the table control 

• Outline Selected Elements – Highlights outline of all elements 
which are selected in rows currently selected in the table control

• Ply Fiber Direction – Displays Fiber Direction on all elements 
which are selected in row(s) currently selected in the table control

*Note: Highlight/Display color is specified on Layup Creation tab of 
Layup Builder Options dialog box
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Layup Builder Tools – All
• Show/Preview Mesh Info – The bottom section offers 

additional tools to further understand what has been 
defined in Layup Stack

• Preview Element Layup – Prompts user to select an 
element, then displays Layup to be potentially created 
for that element in Layup Viewer dialog box
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Laminates – Layup Builder
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Layup Builder Tools – All
• Show/Preview Mesh Info – The bottom section offers additional 

tools to further understand what has been defined in Layup Stack
• Select Rows With Element – Prompts user to select an element, 

then highlights which rows have that element currently selected in 
the table control
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Laminates – Layup Builder
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Layup Builder Tools – Composites HDF5 Only
• Show Composites HDF5 Info – Provides 3 options to display data 

from HDF5 file in the graphics window:
• Show Component – Displays all “triangles” which are found in 

the HDF5 file as a “Filled Color Surface”

• Outline Component – Displays overall outline of each 
component based on the “triangles” found in the HDF5 file 

• Ply Fiber Direction – Displays Fiber Direction using information 
from the HDF5 File

*Note: Display color is specified on Layup Creation tab of Layup 
Builder Options dialog box

Ply Fiber Direction
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Ply Fiber Direction 
(Zoomed In)  Show Component  Outline Component  
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Layup Builder Tools – Composites HDF5 Only
• Select Mesh from Composites HDF5 Ply Info – Uses “triangles” 

and other information from HDF5 file to automatically determine 
which elements should be selected by each row 

• Automatic selection of elements can be adjusted via Composites 
HDF5 Options tab of the Layup Builder Options dialog box

• Show/Preview Mesh Info – The bottom section offers additional 
tools to further understand what has been defined in Layup Stack

• Check Layups vs Composites HDF5 – Lists information about the 
selected element(s) to the Messages window (“worst case”) and 
Data Table (individual elements) which compares what is specified 
for each element with the data from the attached HDF5 file

• This command is meant to perform “spot checking” only, as 
choosing too many elements will result in a large amount of data
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Laminates – Layup Builder
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Layup Builder Columns
Depending on the method used to populate the table control, only certain columns are available
• For New Layup Stack and Load from Layups the available columns are:

• For Attach Composites HDF5 File the available columns are:
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Layup Builder Columns
The following Columns do not have a Context-Sensitive menu
• On/Off – Used by Build Layups tool to know if a row should be considered (box with 

“x”) or not (“empty” box) when creating new Layups and Properties
• Title – Allows user to enter a descriptive title for any row, but title is only used in Layup 

Builder and does not provide any ability to automatically title Layups or Properties

All other Columns have a Context-Sensitive menu used for various purposes
• Composite HDF5 (Component and Layer) – Always automatically populated by 

attached HDF5, but can become editable using context-sensitive menu
• Global Ply – Used to select a Global Ply for a row via a drop-down control
• Material – Used to select a Material for a row via drop-down control or can be 

automatically populated by attached HDF5
• Thickness – Used to enter a Thickness value directly in cell of a row or can be 

automatically populated by attached HDF5
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Layup Builder Columns
• Orientation – This section contains 3 columns used for ply orientation purposes:

• Angle – Used to specify orientation angle of ply to be created by a particular row with 
regard to the “0⁰ direction”

• Typically angle values in cells can be edited directly
• The “0⁰ direction” can be defined:

• By each element itself based on node order (default)
• Within Femap by using Modify -> Update Elements -> Material Orientation command
• By specifying a Fiber Direction in the Direction Column in the Layup Editor

• Direction – Contains information about Material Orientation/Fiber Direction of each row
• If not specified, element orientation or Material Orientation used as “0⁰ direction” 
• If specified, vector or other values specified used as “0⁰ direction” 

• Use Ply to Set Material Orientation (Symbol) – Indicates if the Use Ply to Set Material 
Orientation option is turned on or off for a particular row
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Layup Builder Columns
• Entity Selection – Used to select which elements will be considered for 

each row when automatically creating Layups and Properties
• 3 manual methods for element selection exist via Context-Sensitive menu: 

• Elements selected by ID
• Elements associated to selected Surfaces
• Elements which are referenced by a single selected Group

• When using a Layup Stack populated by Attach Composites HDF5 File, the 
user can have elements automatically selected for each row by using the 
Select Mesh From Composites HDF5 Ply Info tool

*Note: If the mesh in the model or any of the values in the Layup Stack have 
changed since the initial use of the Select Mesh From Composites HDF5 Ply 
Info tool, it should be used again to ensure that all the proper elements are 
assigned to each row
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Layup Builder Columns – Context Sensitive menus
• Composites HDF5 (Component and Layer) – HDF5 Only

• Auto Create Title – Automatically creates a Title based on text and 
values in Component and Layer columns

• Auto Create Global Ply – Automatically creates a Global Ply with 
information from row (“Title” =“Composites HDF5 Layer (Layer ID)”)

• Allow Edit of Composites HDF5 Columns – When on, allows user 
to manually edit text and values in the Component and Layer columns 

• Global Ply – Individual cells can typically be modified via drop-down
• Auto Create Global Ply – Automatically creates a Global Ply based 

on information in each selected row (“Title” varies based on fields)
• Clear Selected – Clears selected Global Ply from selected rows
• Global Ply Manager – Opens Global Ply Manager dialog box
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Layup Builder Columns – Context Sensitive menus
• Material – Individual cells can typically be modified via drop-down

• Material – Opens Select Material dialog box which allows selection 
of an existing Material from a list which can be filtered as well as the 
ability to create a new Material via Define Material dialog box

• Ply Material – Opens Select Ply Material dialog box which allows 
selection of an existing Ply Material from a list which can be filtered 
as well as the ability to create a new Ply Material via Ply Material 
Manager dialog box

• Ply Material Manager – Opens the Ply Material Manager dialog box
*Note: Following option only available when the table control has been 
populated Attach Composites HDF5 File command
• From Composites HDF5 – When on, Material specified by 

information in attached HDF5 file, while when off, Material specified 
via drop-down or other commands
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Layup Builder Columns – Context Sensitive menus
• Thickness – Individual cells can typically be modified directly in cell

• Constant Thickness – Opens Thickness dialog box which allows 
user to enter thickness used for all selected cells 

• From Ply Material – Only used when a Ply Material has been 
selected in the Material cell for a row

• Data Surface – If certain types of Data Surfaces exist in the model, 
one can be selected using the Thickness Data Surface dialog box

*Note: Following options only available when the table control has been 
populated Attach Composites HDF5 File command
• Nominal Composites HDF5 Thickness – Converts Thickness data 

from attached HDF5 file to a Thickness which can be modified  
• From Composites HDF5 – When on, Thickness specified by 

information in attached HDF5 file, while when off, Thickness is 
specified by other commands
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Layup Builder Columns – Context Sensitive menus
• Orientation (Angle, Direction, and Use Ply to Set Material Orientation)

• No Fiber Angle – Clears value of selected cells in Angle column
• Constant Fiber Angle – Sets value of selected cells in Angle column to 

a single specified value 
• Fiber Angle Data Surface - Sets value of selected cells in Angle 

column to reference a scalar-based Data Surface

• No Fiber Direction – Clears vector and/or other values of selected cells 
in the Direction column 

• Fiber Direction – Specifies vector values of selected cells in the 
Direction column using Standard Vector Definition dialog box 

• Fiber Direction Data Surface – Specifies vector values of selected cells 
in the Direction column using a vector-based Date Surface
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Layup Builder Columns – Context Sensitive menus
• Orientation (Angle, Direction, and Use Ply to Set Material Orientation)

• Fiber Angle and Direction From Composites HDF5 – When on, 
values for both the Angle and Direction cells in a particular row are 
specified by information in attached HDF5 file

• Use Ply to Set Material Orientation – When on, uses the vector or 
other values specified in the Direction column to set the Material 
Orientation of elements selected in Entity Selection Column

• If user wants to set the same Material Orientation/Fiber Direction for all 
elements currently selected in Layup Builder, this option and Direction 
only need to be set in “Row 1”
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Layup Builder Columns – Context Sensitive menus
• Entity Selection – Values cannot be edited directly within cell

• Select Elements – Use Standard Entity Selection dialog box for elements 
to select any number of elements for selected row(s)

• Select Surfaces – Use Standard Entity Selection dialog box for surfaces to 
select elements associated any number of surfaces for selected row(s)

• Select Group – Use Select Group dialog box to select a single group which 
references elements for selected row(s)

• Clear Selected – Clears all selected entity types from selected row(s)

• Errors – While the cells in the Errors column do not actually have a Context-
Sensitive menu, if a cell is Red, place the cursor over the cell and a Tooltip 
will appear explaining why a particular row is invalid
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Model -> Laminates -> Add Plys to Mesh command
• Allows user to add plys to any number of selected laminate shell elements by automatically 

creating all Layups and corresponding Properties needed to update the elements based on 
the settings for the Where to Add, Ply Type, Ply Definition, and Nastran SOL 401/402 Property 
sections in the Add New Ply to Mesh dialog box
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Model -> Laminates -> Add Plys to Mesh command
• Title – Enter a descriptive title, if desired
• Where to Add – Choose Top, Bottom, Above Global Ply, 

or Below a Global Ply 
• Ply Type – Choose Ply, Ply Material, Layup, Layup –

Symmetric, Layup – Anti, or Layup – AntiSymmetric
• Ply Definition – This section changes depending on 

option set in Ply Type:
• Ply – Specify Material, Thickness, and Angle
• Ply Material – Specify Ply Material and Angle
• Layup (all options) – Specify Layup and “Base” Angle 

for Layup
• Nastran SOL 401/402 Property – Specify Ply Failure 

Theory for SOL 401/402 when Ply Type is set to Ply
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Model -> Laminates -> Add Plys to Mesh command – Original Model has 3 Layups/Properties
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Model -> Laminates -> Add Plys to Mesh command – Elements where ply will be added
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Model -> Laminates -> Add Plys to Mesh command – Updated Model has 6 Layups/Properties
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The Connect -> Fluid Region command displays Fluid Region dialog box
The Fluid Options section contains two options:
• Virtual Fluid - Used to specify options and entities written to MFLUID entry 
• Incompressible Fluid Surface – Used to specify options and entities written to INCMPFL entry
Defined By – Regardless of option selected in Fluid Options, used to select either faces of elements 
themselves or determine element faces based on association to selected geometric surfaces
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Fluid Region – Incompressible Fluid Surface
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The Connect -> Fluid Region command displays Fluid Region dialog box
The Fluid Options section also contains additional options for Incompressible Fluid Surface
• Free Surface – Specifies whether fluid volume contains free surface or is completely enclosed by structure 

• If fluid volume contains a free surface, specify whether free surface is sloshing or non-sloshing
• Gravity – When free surface is allowed to slosh, sets the acceleration due to gravity
• Comp. Modes – Number of modes associated with sloshing surface after Component Mode Synthesis 

(CMS) reduction



Simcenter Femap 2401
Fluid Region – Incompressible Fluid Surface
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Defining the fluid region for the defined fluid mass 
approach works differently than defining the fluid 
region for the virtual fluid mass (MFLUID) approach
• Defined Fluid Mass – Specify the free surface for 

the incompressible fluid
• If the fluid volume is fully enclosed, then it does not 

contain a free surface and the region should be 
empty

*Note: When modeling the structure, the best practice 
is to use plate elements and avoid using 3D elements

• Virtual Fluid Mass – Specify the fluid-structure 
interface, which are “wetted” plate elements that 
define the structural portion of the fluid boundary 

Structure (Plate Elements)

Fluid (Solid Elements)

Fluid Free Surface Region
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Updated Mesh -> Geometry -> Surface to attempt to use the Surface Interior Growth Factor specified 
via the Mesh -> Mesh Control -> Size on Surface or Mesh -> Mesh Control -> Size on Solid when 
Mesher is set to “Tri” or “Quad” and “Body/on Mesh” and Mapped Meshing Options is set to “Off”
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Growth Ratio = 2.0Mesh Size = 6.0 No Growth Ratio

Quad Mesh Example
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Growth Ratio = 2.0Mesh Size = 6.0 No Growth Ratio

Triangle Mesh Example
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Femap currently contains three different “pipelines” for 
graphics: “original OpenGL”, “Performance Graphics”, 
and “Unified Graphics Architecture (UGA)

When the Best Possible or Performance Graphics option 
is turned on in File -> Preferences, everything that is 
supported by “Performance Graphics” is drawn using 
more modern OpenGL technology and everything which 
is not supported is drawn using “original OpenGL”

The drawback to the original two “pipelines” is that some 
entity types only appear “as expected” in the graphics 
window in “original OpenGL”, as line style, line width, fill 
style, and transparency are not supported by 
“Performance Graphics”
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Performance Improvements – Unified Graphics Architecture Update
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In Femap 2301, an effort to improve graphics performance 
across all aspects of Femap was started, which is still 
intended to span across multiple releases

This new Unified Graphics Architecture (UGA) uses a 
single “pipeline” and when fully implemented, UGA will 
provide a better experience for the user in quality, 
performance, and hardware support

In addition, UGA will support line style, line width, fill style, 
and transparency along with being able to better support 
users using Intel graphics 

Once UGA is completed, both the “Performance Graphics” 
and “original OpenGL” pipelines will be removed
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UGA is turned on by default but can be turned off using Unified 
Architecture option on the Graphics tab of File -> Preferences 

For 2401, “Unified Architecture…” is now also a button which 
accesses the Unified Architecture Options dialog box:

This dialog box allows selection of OpenGL version as well as 
ability to use/not use UGA for supported entity types*
*Note: ONLY use if problem is encountered when using UGA



Simcenter Femap 2401
Performance Improvements – Unified Graphics Architecture Update
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For Femap 2401, Nodes have been added to the UGA 
“pipeline”, which includes support for all display options for 
nodes which previously existed in the other two “pipelines”
These entity types were already supported in 2301 and 2306:
• Coordinate Systems
• Geometric Entities

• Points
• Mesh Points
• Curves
• Composite Curves
• Surfaces
• Boundary Surfaces
• Solids

• Geometry-based Loads and Constraints
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In previous versions of Femap, the Entity Editor was not 
populated with any information when an Analysis Set was 
highlighted in the Analyses branch of the Model Info Tree

As an initial implementation for Femap 2401, the Entity 
Editor is now populated with a subset of information 
available for each Analysis Set:
• Title – Title of the Analysis Set (editable)
• Solver – Analysis Solver (read-only)
• Analysis Type – Analysis Type (read-only)
• Results Destination – If specified, displays full path to 

directory where output will be sent by the solver (editable) 
• Portion of Model to Write – Displays ID and name of 

Group to be used to write a portion of the model (editable)
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Normal Modes (SOL 103) and Modal Frequency Response (SOL 111) analysis on models that contain 
incompressible fluids where fluid is defined with solid elements is possible with Simcenter Nastran 
• The defined fluid mass approach is useful for complicated fluid volume shapes
• Previous versions of Femap included support for the virtual fluid mass method (MFLUID), which used 

boundary elements to model the fluid volume
• Defining an Incompressible Fluid Surface is done using Connect -> Fluid Region command
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Various options are available for configuring the 
analysis to optimize for efficiency. These are available 
in normal modes and modal frequency response 
analysis sets within the new “Incompressible Fluid 
Options” branch (Note: Not in “Next/Prev chain”)
• Incompressible Fluid Options – Specify options for 

modeling incompressible fluids with fluid elements

• FSI Modeling Parameters – Define the modeling 
parameters for the interface between the fluid and the 
structure (FSI = Fluid-Structure Interaction)

• FSI Control Parameters – Various control parameters 
for configuring the Fluid-Structure Interaction
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Incompressible Fluid Options
When Activate Incompressible Fluid Options is turned on, 
writes INCMOPT Bulk Data entry with specified values
• Modal Calc Method – Specifies the method for the modal 

calculation with the incompressible fluid
• 0..Subspace Iteration (SUBS)
• 1..Dry Modes plus Residual Vectors (DRYMODES)
• 2..ARPACK (proposed for Simcenter Nastran 2406)

• Scale Factor – Only used for “1..Dry Modes Plus Residual 
Vectors (DRYMODES)” method, and is applied to the 
frequency range or number of modes for the modal 
calculation with the incompressible fluid to determine 
frequency range or number of modes for the modal 
calculation without the incompressible fluid
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Incompressible Fluid Options
• Surface Flatness Tolerance – Tolerance for determining 

whether the free surface is sufficiently flat to perform the 
modal analysis with the incompressible fluid

• Block Size – Only used for “0..Subspace Iteration 
(SUBS)”method, the number of eigenvectors calculated 

• Max Iterations for SUBS – Only used for “0..Subspace 
Iteration (SUBS)”, maximum allowable number of iterations 
for convergence

• Compute G-set INCMPFL Mass – Option to compute rigid 
body incompressible fluid mass and output it to the .f06 file
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Incompressible Fluid Options
Parameters – When on, writes PARAM,SLOSHCMS,“n”
• SLOSHCMS – Parameter for specifying whether the 

software performs Component Mode Synthesis (CMS) 
reduction on the sloshing surface and retains “n” modes

• If both this field and Comp. Modes field on Fluid Region 
are specified, Comp. Modes value takes precedence for 
the incompressible fluid volume sloshing surface

FSI Modeling – Opens FSI Modeling Parameters dialog box 
used to specify advanced options such as coupling controls 
and search distances (writes ACMODL Bulk Data entry)

FSI Control – Opens FSI Control Parameters dialog box used 
to specify SKINOUT as well as if coupling data with pairing 
information is written (writes FLSTCNT Case Control entry)
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FSI Modeling Parameters – Accessed by FSI Modeling button
When Activate Fluid-Structure Interface Modeling Parameters is 
turned on, writes ACMODL Bulk Data entry with specified values 
• Type of Coupling (CTYPE) – Determines which governing 

equation will be used by choosing either:
• 0..Two Way Coupling (STRONG)
• 1..Effect of Structure on Fluid Only (WEAK)

• Search Units (SRCHUNIT) – Controls how values specified for 
Outward Norm Srch Dist (NORMAL) and Inward Normal Srch Dist
(INTOL) are used by choosing either:

• 0..Relative – Values used as scale factors applied to maximum 
edge length of a fluid element free face (L max in figure)

• 1..Absolute – Values used as physical distances 



Simcenter Femap 2401
Simcenter Nastran – Dynamic Analysis with Defined Fluid Mass

Unrestricted | © Siemens 2024 | Siemens Digital Industries SoftwarePage 56

FSI Modeling Parameters – Accessed by FSI Modeling button
• Outward Norm Srch Dist (NORMAL) – Value used to determine 

outward normal search distance (L outward in figure)
• If the fluid and structural element free faces are within search 

distance of one another and satisfy value specified for Angle 
Tolerance (OVLPANG), they are coupled

• Inward Norm Srch Dist (INTOL) – Value used to determine the 
inward normal search distance (L inward in figure)

• If the fluid and structural element free faces are within search 
distance of one another, they are coupled

• Angular Tolerance (OVLPANG) – Angular tolerance in degrees 
used to decide whether a fluid free face and a structural face can 
be considered overlapping

• If the angle between the normals of the fluid and structural faces 
exceeds the value, they are not coupled
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FSI Modeling Parameters – Accessed by FSI Modeling button
Figure shows outward (L outward) and inward (L inward) normal search 
distances for a quadrilateral free face of a fluid element, as well as 
maximum edge length of a fluid element free face (L max), which is 
only used when Search Units (SRCHUNIT) is set to “0..Relative”
• For each fluid element free face, the search for a structural free 

face with which to couple continues until a structural face is 
identified or search distance is reached

• Coupling Method (AREAOP) – Option to choose:
• 0..Recommended Method
• 1..RBE3 Method – Alternative fluid-structure coupling method, 

which applies an area correction and removes parallel 
disconnected faces from the coupling
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FSI Control Parameters – Accessed by FSI Control button
When Activate Fluid-Structure Interface Control Parameters is 
turned on, writes FLSTCNT Case Control entry with specified values 
• Symmetric Request (ACSYM) – Specifies if fluid-structure analysis is 

symmetric or not by choosing either:
• 0..NO – Solution is non-symmetric
• 1..YES – Solution is symmetric

• Particle Vel Output Type (ACOUT) – Specifies the type of output 
created by a FORCE Case Control entry by choosing either:

• 0..Peak value output (PEAK)
• 1..Root-mean-square output (RMS)

• Reference Pressure (PREFDB) – Specifies value for reference 
pressure
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FSI Control Parameters – Accessed by FSI Control button
• Couple Solution (ASCOUP) – Specifies if a coupled fluid-structure 

analysis should be performed or not by choosing either:
• 0..NO – Solution is not coupled
• 1..YES – Solution is coupled

• Coupling Information (SKINOUT) – Specifies if coupling data with 
the pairing information is output, for debugging, by choosing from:

• 0..NONE – Coupling data is not output
• 1..PUNCH – Coupling data is written to *.dat and Punch (*.pch) files 

(solution proceeds, only coupled free faces are written)
• 2..FREEFACE – Coupling data is written to *.dat and Punch (*.pch) 

files as well as to the coupling datablock in .op2 file (solution 
proceeds, both coupled and uncoupled faces are written)

• 3..STOP – Works like “2..FREEFACE”, but solution stops 
immediately after pairing information is written
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FSI Control Parameters – Accessed by FSI Control button
• Coupling Matrix to PCH (AGGPCH) – Requests if output of the fluid-

structure coupling matrix AGG will be written to the Punch (*.pch) file 
by choosing either:

• 0..NO – Fluid-Structure coupling matrix output is not written
• 1..YES – Fluid-Structure coupling matrix output is written

• Matrix from SFE AKUSMOD (SFEF70) – Requests import of a fluid-
structure coupling matrix created by SFE AKUSMOD by choosing 
either:

• 0..NO – Coupling matrix is not imported
• 1..YES – Coupling matrix is imported
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Updated name of “Control Options” in Analysis Set Manager tree 
structure to “Strategy Parameters” and added “Non-Default Values” 
branch below which only contains items with non-default values

Changed name of dialog box to “Strategy Parameters (NLCNTL)” 
and enhanced it to feature tabs (former “section” in dialog boxes):
• Time Control (Time Step Control and Time Integration)
• Iteration/Convergence (Convergence Parameters)
• General Sol (Solution Parameters and Time Step Control)
• Stiffness (Stiffness Parameters)
• Creep/Plasticity (Creep/Plasticity and Other Options)
• Contact/ Bolt (Contact, Bolt Preload, and Other Options)

Added Default Tab and Default All buttons
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Additions and Updates for Multi-Step Structural (SOL 401):
• Strategy Parameters (NLCNTL) – Iteration/Convergence tab

• Added Incremental Rotation Limit in Iteration (RTOLB) value
• Strategy Parameters (NLCNTL) – Stiffness tab

• Added Include Stress Stiffening at First Iteration (STKFRST) 
option

• Strategy Parameters (NLCNTL) – Creep/Plasticity tab
• Changed default for Adjust Integration Factor (CRLIMR) from 

0.0 to 1.0

Updated for Multi-Step Nonlinear Kinematic (SOL 402)
• Strategy Parameters (NLCNTL) – Plasticity/Creep tab

• Changed default for Creep Integration Factor (CRINFAC) 
from 0.5 to 1.0
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To allow ABAQUS users to work in a more familiar 
environment when setting up an analysis, Femap 2401 now 
uses terminology and methodologies similar to those found 
in other Pre-and-Post Processers and the solver itself

As a first step, a newly created Analysis Set for ABAQUS 
will now always include:
• Initial Step – Used to set Default Constraints, Default 

Connectors, and Initial Conditions for the Analysis
• Step 1 – Used to specify Options, Boundary Conditions, and 

Output Requests for the Analysis Step

Additional “Steps” can then be created, as needed, and the 
type of analysis to perform in each step can be specified
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2306 and Below 2401 and above
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Summary of “new” vs “old” Analysis Set paradigm
Initial Step – Did not exist before and is used to specify overall Boundary 
Conditions for the entire analysis
• Constraints* – Specify Default Constraint Set 
• Initial Conditions* – Specify Initial Conditions 
• Constraint Equations* – Specify if constraint equations for the Default 

Constraints come from the Constraint Set specified in Constraints or a 
different Constraint Set

• Contact Sets and Glued Sets** – Connectors to use, choose between:
• All Connectors – Use all Connectors of corresponding Type
• Connection(s) – Use selected Connector Set of corresponding Type
• None – Use no Connectors of corresponding Type

*Note: Previously done in “Global Requests and Conditions”
**Note: Could not be specified in previous versions of Femap
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Summary of “new” vs “old” Analysis Set paradigm
Step “n” – Used to specify Options, Boundary Conditions, and 
Output Requests for a “Step”
• “Step 1” automatically created with new Analysis Set
• To create a “Step”, highlight existing “Step” and click “New” button

• If there are no “Steps” defined, “No Cases Defined” is shown

Analysis Step – Top-level of each “Step”
• Step ID – Automatically increments to next available ID in Femap, 

but can be changed to another value
• “Step ID” only used to control order of “Steps” in Analysis Set

• Title – Optional, but if Analysis Set is “Untitled”, Title of Load Set 
selected in Boundary Conditions is used as NAME for *STEP 

• Manual Control – Can be used to add text to Start/End of “Step”
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Summary of “new” vs “old” Analysis Set paradigm
Step “n” – Used to specify Options, Boundary Conditions, 
and Output Requests for a “Step”

Options* – ABAQUS Step Options dialog box allows user to:
• Enter Time Step Options
• Enter Dynamic Step Options (when applicable)
• Choose an option for Amplitude/Loads/Constraints
• Select various Other Options
• Select various Contact Controls
*Note: This dialog box did not change for 2401 and values 
previously specified in ABAQUS Step Options dialog box in 
Global Requests and Conditions must now be specified in
ABAQUS Step Options dialog box in “Step 1”
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Summary of “new” vs “old” Analysis Set paradigm
Step “n” – Used to specify Options, Boundary Conditions, and Output 
Requests for a “Step”

Boundary Conditions
• Constraints* – Specify Constraint Set to use for Step
• Loads* – Specify Load Set to use for Step
• Contact Sets** – Non-Glue Connectors to use for Step, choose between:

• All Connectors – Use all Connectors of corresponding Type
• Connection(s) – Use selected Connector Set of corresponding Type
• None – Use no Connectors of corresponding Type

*Note: Boundary Conditions which would previously have been specified in 
Global Requests and Conditions must now be specified in “Step 1”
**Note: Could not be specified in previous versions of Femap
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Summary of “new” vs “old” Analysis Set paradigm
Step “n” – Used to specify Options, Boundary Conditions, 
and Output Requests for a “Step”

Output Requests* – Select output quantities and specify 
other options in Output Requests dialog box
• Nodal – Select output to recover for nodes
• Elemental – Select output to recover for elements
• Customization – Specify if output should be recovered at 

Element Corners and/or Integration Points as well as 
specify which output files should be created by ABAQUS

*Note: This dialog box did not change for 2401 and values 
previously specified in Output Requests dialog box in Global 
Requests and Conditions must now be specified in Output 
Requests dialog box in “Step 1”
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What’s new 
Simcenter Femap 2401
Managed Environments
Geometry
Preprocessing
Meshing
Performance Improvements
Analysis and Solver Support
Postprocessing
Miscellaneous and API



Simcenter Femap 2401
Postprocessing – Dynamic Analysis with Defined Fluid Mass

Unrestricted | © Siemens 2024 | Siemens Digital Industries SoftwarePage 71

Once Simcenter Nastran has completed a modal or frequency response analysis which included 
an Incompressible Fluid Surface, the sloshing modes can be postprocessed by using the File -> 
Import -> Analysis Model command to import the 2D plot-only mesh internally generated by 
Nastran (PLOTEL elements which cover the sloshing free surface), then animate the modes
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What’s new 
Simcenter Femap 2401
Managed Environments
Geometry
Preprocessing
Meshing
Performance Improvements
Analysis and Solver Support
Postprocessing
Miscellaneous and API
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Femap 2301:
• Initial Implementation
Femap 2306:
• Find Tools in Toolboxes/Panes and Use “Keywords”
Femap 2401:
• Feature to pop-up a command when user “hovers-over” a 

matched command which is useful to identify location of 
command in Femap user interface

• Allow users to see matched commands as they type text in 
Command Finder edit box

• Improved layout of the matched command list to provide 
extra information, such as currently assigned shortcut, 
location of the command, and access help

• A hyperlink to allow users to search online for the query
• Support for searching within toolbars and Custom/User Tools
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Added Help -> Manage Licensing command 
which can be used to change the licensing 
method for Femap at any time
• Eliminates need to shut down Femap and 

use one of the go_*.bat files in the Femap 
install directory to change licensing method

• The Manage FEMAP Licensing dialog box 
changes depending on which option is 
chosen in Select License Type

• An indicator at the top of the dialog box 
provides a “visual cue” to the user that 
Femap is:

• Properly Licensed (Green-Filled Circle)
• Not Properly Licensed (Red-Filled Circle)
…along with other information
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• Helpful information about each license type 
is now provided in the text section below 
the License Location field

• When using either FlexLM License Server 
or Bundle, additional icons and buttons are 
available

• “…” – Browse to license file location
• “*” – Generate FQDN (Fully Qualified 

Domain Name)
• “Test Connection” button – Performs a 

“ping” of the server machine
• Show Modules/Show Users button toggles 

and will list Modules or Modules and Users 
to the Available Modules section
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• Added NasMsnlCntRTOLB and NasMsnlCntSTKFRST to Analysis Case Object
• Added NasMsnlCntRTOLB, NasMsnlCntSTKFRST, NasBulkSLOSHCMS, NasBulkSLOSHCMSVal, 

NasACMODLExport, NasACMODLNORMAL, NasACMODLOVLPANG, NasACMODLSRCHUNIT, 
NasACMODLINTOL, NasACMODLAREAOP, NasACMODLCTYPE, NasACMODLFSETEntityOpt, 
NasACMODLFSETOpt, NasACMODLFSET, NasACMODLSSETEntityOpt, NasACMODLSSETOpt, 
NasACMODLSSET, NasFLSTCNTExport, NasFLSTCNTACSYM, NasFLSTCNTACOUT, 
NasFLSTCNTASCOUP, NasFLSTCNTREFDB, NasFLSTCNTKINOUT, NasFLSTCNTAGGPCH, 
NasFLSTCNTFEF70, NasINCMOPTOn, NasINCMOPTExport, NasINCMOPTETHOD, 
NasINCMOPTSF, NasINCMOPTSFTOL, NasINCMOPTBSIZE, NasINCMOPTNITER, and 
NasINCMOPTRBFLMASS to Analysis Manager Object

• Added IsINCMPFL, INCMPFLSurfType, INCMPFLGrav, and INCMPFLCmsModes to Connection 
Region Object

• Added ViewAxesSize to View Object
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• Added InnerLoopCurvesAsSet Method to Solid Object

• Added feCheckCoincidentElemQuick function

• Added Pref_UnifiedArchitectureOpenGL and Pref_UnifiedArchitectureOpenGL to specify the options in 
the Unified Architecture Options dialog box which is accessed by the Unified Architecture button on the 
Graphics tab of File -> Preferences 
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