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Our Expertise
- Design: From initial concept development to detailed structural design
- Analysis: Comprehensive structural, fluid, acoustic, and thermal analysis services
- Test: Industry-leading structural test services for extreme loading environments

Who We Are
We are an employee-owned small business with a full-time staff of nearly 

200, more than 160 of whom are degreed engineers
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ATA is a Value-Added Reseller for 
Siemens Digital Industries Software

ATA offers training, free resources, and hotline support 
for a variety of Siemens products.
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ATA Engineering is recognized as a Certified Expert Partner with validated expertise in Femap, STAR-CCM+, and Simcenter 3D.
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Simcenter Femap 2301
Teamcenter Integration

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Allows Femap files to be 
managed from within the 
Teamcenter Environment

Interaction with Teamcenter is 
accomplished through the 
PDM -> Teamcenter menu or 
Teamcenter toolbar

New PDM menu also contains 
Xcelerator Share menu 
(formally File -> Share menu) 
and References command 
(formally File -> References 
command)



Simcenter Femap 2301
Teamcenter Integration

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Femap requires the Teamcenter Rich Application Client (RAC) for implementation
• “Items” need to be created in RAC to use with Femap

Note: Interaction with Teamcenter Active Workspace planned for future version



Simcenter Femap 2301
Teamcenter Integration

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Sign-in to connect to user's Teamcenter 
Environment
• Allows file check-in and check-out
• Revisions and revision history 

documentation

Create a dataset that hosts the Femap 
.modfem file directly in Teamcenter

Save and Open Femap models to/from 
the Teamcenter database
• PDM -> Teamcenter -> Save allows 

user to check-in file
• PDM -> Teamcenter -> Open allows 

user to check-out file



Simcenter Femap 2301
Teamcenter Integration

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

The PDM -> Teamcenter -> Import JT Assembly 
command imports Assembly Item IDs from a 
Teamcenter Dataset into Femap
• Femap uses a generated JT model on each item 

revision to import the geometry
• Femap looks at each assembly in Teamcenter 

using the BVR (BOM View Revision) to find the 
associated part IDs and sub-assembly IDs

• The JT files can be generated/saved from 
multiple CAD systems within Teamcenter

• Note: JT files can be manually imported one-
by-one into Teamcenter if they are stored on 
the disk
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Simcenter Femap 2301
Geometry – Midsurfacing Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Two new options have been added to the 
Geometry -> Midsurface -> Automatic 
command, both designed to allow more 
flexibility during the midsurfacing workflow

Remove Holes – When used, any internal 
holes in the resulting midsurface
geometry will be deleted

Keep Untrimmed Midsurfaces – When 
used, any midsurface which is found but 
not trimmed properly is kept instead of 
being deleted 



Simcenter Femap 2301
Geometry – Midsurfacing Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Original Geometry



Simcenter Femap 2301
Geometry – Midsurfacing Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Remove Holes option Turned Off



Simcenter Femap 2301
Geometry – Midsurfacing Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Remove Holes option Turned On



Simcenter Femap 2301
Geometry – Midsurfacing Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Keep Untrimmed Midsurfaces option Turned On
(both Original Geometry and Midsurfaces shown for clarity) 



Simcenter Femap 2301
Geometry – Miscellaneous

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Added support for reading Points in the Catia V4 direct geometry interface

Updated various tools in the Meshing Toolbox which can be used to move/project 
“Femap points” which also modify curves, surfaces, and solids created with Femap’s
“Standard” Geometry engine (i.e., non-Parasolid geometry)
• Especially helpful when updating wireframe models which contain “Femap 

Curves” meshed with line elements, as nodes are moved with curves

Improved the Group -> Curve -> From Node and Group -> Surface -> From Node 
commands to work with non-Parasolid FEMAP geometry
• Previously these commands only worked with Parasolid geometry
• This improvement was also made to associated selection methods in standard 

entity selection dialog, CurvesAsSet and SurfacesAsSet methods on API Point 
object, and Surfaces and SurfacesAs Set methods on API Curve object
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Simcenter Femap 2301
Preprocessing – Element Add | Remove

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Simulation Entities used to perform 
element addition and removal when 
using Simcenter Nastran SOL 401

Accessed by Model -> Simulation 
Entities -> Element Add | Remove 
command or via Model Info tree

Both Element Add | Remove Entities 
and Sets referencing multiple 
Entities can be created

Creates ELAR, ELAR2, or 
ELARADD entries in Nastran input 
file



Simcenter Femap 2301
Preprocessing – Element Add | Remove

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Element Add | Remove Manager
• New Add | Remove – Creates 

ELAR or ELAR2 entity
• Add | Remove Set – Creates 

ELARADD from existing entities
• Edit Selected
• Show Selected
• Convert to ELAR – Creates 

multiple ELARs from ELAR2
• Convert to ELAR2 – Coverts 

ELAR(s) into ELAR2(s)
• Delete and Delete All
• Copy
• Renumber



Simcenter Femap 2301
Preprocessing – Element Add | Remove

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Available criteria types for Element Add | Remove
• Time – Available for Addition or Removal
• Inelastic Strain – Available for Removal only
• Mechanical Strain – Available for Removal only



Simcenter Femap 2301
Preprocessing – Element Add | Remove

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Available criteria types for Element Add | Remove
• Time – Available for Addition or Removal
• Inelastic Strain – Available for Removal only
• Mechanical Strain – Available for Removal only

Two options to create Element Add | Remove entity
• ELAR – Selected elements all use same value

• Elements specified by choosing existing 
Group or by using Select button



Simcenter Femap 2301
Preprocessing – Element Add | Remove

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Available criteria types for Element Add | Remove
• Time – Available for Addition or Removal
• Inelastic Strain – Available for Removal only
• Mechanical Strain – Available for Removal only

Two options to create Element Add | Remove entity
• ELAR – Selected elements all use same value

• Elements specified by choosing existing 
Group or by using Select button

• ELAR2 – Individual value can be specified for 
each element

• Elements selected using Select Elements 
icon above table, with other icons available 
to highlight, delete, or clear table

• Values can be updated directly in the table



Simcenter Femap 2301
Preprocessing – Element Add | Remove

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Element Add | Remove Set
• Creates ELARADD
• Highlight any number of 

Element Add | Remove entities 
in Available Inputs and click 
Add to add them to Referenced 
Inputs

• Remove removes highlighted 
entities from Referenced Inputs

• Add All adds all Available Inputs 
to Referenced Inputs

• Remove All removes all items 
from Referenced Inputs



Simcenter Femap 2301
Preprocessing – Aero Spline Enhancement

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

When choosing which Aero Boxes 
to include for an Aero Spline, there 
are now two options:
• All Boxes – Chooses all Aero 

Boxes on the Aero Panel/Body 
selected by CAERO ID

• Custom – Allows selection of a 
subset of Aero Boxes on the 
selected Aero Panel/Body

All Boxes allows user to update 
definition of an Aero Panel/Body 
and not have to update the Aero 
Spline when using all Aero Boxes 
on the Aero Panel/Body



Simcenter Femap 2301
Preprocessing – Connection Properties

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Multistep Structural (401) tab
• Contact Property (BCTPARM) section

• Added Contact Algorithm drop-down

These items have been removed as they are no 
longer used
• Contact Property (BCTPARM) section

• *Closed Gap Tolerance (GAPTOL)
• *No Separation (NOSEP)

• Dialog box accessed by More Options… button
• Stiffness Stabilization (KSTAB)



Simcenter Femap 2301
Preprocessing – Connection Properties

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

MultiStep Structural (401) tab
• Dialog box accessed by More Options… 

button, Added:
• *Friction Behavior Selection drop-down
• *Critical Slip value
• *Friction Param 1 value
• *Friction Param 2 value
• *Critical Sliding Velocity value
• *Frict vs Sliding Velocity drop-down
• *Frict vs Time drop-down
• *Frict vs Temp Velocity drop-down
• Remove Small Force Magnitude Pairs value

• Updated:
• *Adjustment Tolerance (ADJUST) - can now 

be toggled and also accepts negative values



Simcenter Femap 2301
Preprocessing – Connection Properties

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Multistep Kinematic (402) tab
• Contact Property (BCTPAR2) section

• Added Normal Modulus Scaling value

• More Options… button added to 
accommodate new options

• Moved from Contact Property (BCTPAR2) 
section to dialog box accessed by More 
Options… button

• Regularization Models drop-down and 
Value value (also added Tangential 
Contact Stiffness Scale value)

• Normal Reg. Type drop-down and Value
value



Simcenter Femap 2301
Preprocessing – Connection Properties

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

MultiStep Kinematic (402) tab

• Dialog box accessed via More Options… 
button, Added:

• Adjust Grid Points value
• Enable Contact Friction Boolean
• Slide Distance Computation drop-down
• Stabilization Damping Option drop-down
• Normal Damping Scaling value
• Tangential Damping Scaling value
• Gap Tolerance Scale Factor value



Simcenter Femap 2301
Preprocessing – Groups

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Updated Group -> Operations -> Condense
• Always updates group to use “ID rules” but now condensed group only 

contains IDs of existing entities

Added Group -> Operations -> Reduce to Existing
• Works like Group -> Operations -> Condense but it updates each rule type 

to contain its existing entities
• Does not condense the rules down to “ID rules” so user retains the same 

functionality of the Group

Updated Group -> Operations -> Automatic Add
• Now prevents adding entities that are being renumbered to new IDs
• Previously they were added because a new ID was being created even though 

it was not a new entity



Simcenter Femap 2301
Preprocessing – Miscellaneous

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Updated how Constraint Equations are shown in the Data Table
• Previously, Nodes with multiple DOF did not show the Node ID with each DOF, 

which caused columns to be misaligned and mislabeled if user added multiple 
equations with differing numbers of DOF per node

• ID of the Constraint Equation within the Constraint Set is now shown as the ID 
instead of the selected node, as was previously done

Updated toolbar commands that show multiple different icons so that all 
instances of those commands are correctly updated if user places such a 
command on existing or custom toolbars

Added “8..Fluid” and “7..Other” as material types which can be selected in the 
standard entity selection dialog box when Method^ is set to Type and are also 
now selected when using Select All when Method^ is set to Type.
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Simcenter Femap 2301
Meshing – Body Mesher Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Mesh Points (hard points) created 
via the Mesh Point Editor are now 
recognized by Body Mesher both 
when using the Mesh -> Bodies 
command or when using the Mesh 
-> Geometry -> Surface command 
with Mesher set to Body/on Mesh

Midside Nodes tab added to dialog 
box of Mesh -> Bodies command 
to allow projection of midside
nodes toward associated surfaces 
and curves, limited by user-defined  
distortion angle

Mesh Points specified on Geometry



Simcenter Femap 2301
Meshing – Body Mesher Enhancements
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Mesh Points recognized by Body Mesher Zoomed in on single mesh point



Simcenter Femap 2301
Meshing – Mesh -> Mesh on Mesh Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Line elements connected to other 
element types can now be updated 
when using Mesh -> Mesh on Mesh 
command
• Allows mesh containing line 

element stiffeners to be 
completely refined or un-refined

• Line Elements tab added which 
controls if adjacent line elements 
should be treated together or 
individually during remeshing 
based on a user-defined  
Orientation/Offset Deviation Limit 
Angle Along Edge value

Original Model



Simcenter Femap 2301
Meshing – Mesh -> Mesh on Mesh Enhancements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Refined Mesh Un-refined Mesh



Simcenter Femap 2301
Meshing – Mesh Sizing Propagation Options

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Added Edge Imprinting section to Mesh Sizing 
Propagation Options dialog box accessed by 
various commands on Mesh -> Mesh Sizing 
menu or via icon in Mesh Control Explorer pane
• Added Auto Close Imprint Gaps option –

when on, will extend projected imprints to 
closest edge when distance from end of 
imprinted curve to closest edge is within 
tolerance

• Two options for tolerance
• Auto Tolerance – uses default “Merge 

Tolerance” (Length of “Model Box 
Diagonal”/10,000) divided by 10

• Specified Tolerance – uses value supplied 
by user



Simcenter Femap 2301
Meshing – Miscellaneous

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Updated Mesh -> Geometry Preparation command
• Added confirmation question and warning message if Suppress Internal 

Voids option is selected and any void is much larger than the specified 
mesh size

• Intended to prevent accidental suppression of large void regions like the 
inside of hollow tubes with closed ends

Updated Mesh -> HexMesh Bodies command to better match specified mesh 
sizes in very specific case where Size Surface if All Curves Sized option is 
turned on, all curves on either a required surface are sized or All Sized Curves 
option is turned on, and curve sizing is close to Target Element Size value

Enhanced the Mesh -> Editing -> Cohesive Meshing command to properly 
support inserting Cohesive elements at a location where some portions of the 
mesh could be missing adjacent elements over part or all of the area. 
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Simcenter Femap 2301
Performance Improvements – Unified Graphics Architecture

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Currently, Femap contains two different “pipelines” 
for graphics: “Performance Graphics” and “original 
OpenGL”

When the Best Possible or Performance Graphics 
option is turned on in File -> Preferences, 
everything that is supported by “Performance 
Graphics” is drawn using more modern OpenGL 
technology and everything which is not supported 
is drawn using “original OpenGL”

The drawback to having two different “pipelines” is 
that some entity types only appear “as expected” 
in the graphics window in “original OpenGL”, as 
line style, line width, fill style, and transparency are 
not supported by “Performance Graphics”



Simcenter Femap 2301
Performance Improvements – Unified Graphics Architecture

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

In an ongoing effort to improve graphics 
performance across all aspects of Femap a new 
Unified Graphics Architecture (UGA), which uses a 
single “pipeline”, will be implemented over the next 
few releases

When fully implemented, UGA will provide a better 
experience for the user in quality, performance, 
and hardware support and both the “Performance 
Graphics” and “original OpenGL” pipelines will be 
removed

In addition, UGA will support line style, line width, 
fill style, and transparency along with being able to 
better support users using Intel graphics 



Simcenter Femap 2301
Performance Improvements – Unified Graphics Architecture

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

UGA is turned on by default but can be turned off 
using Unified Architecture option on the Graphics
tab of File -> Preferences

The following entity types are currently supported:
• Coordinate Systems
• Geometric Entities

• Points
• Mesh Points
• Curves
• Composite Curves
• Surfaces
• Boundary Surfaces
• Solids
• Volumes (may be removed in future version)

• Geometry-based Loads and Constraints



Simcenter Femap 2301
Performance Improvements – Miscellaneous

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Improved the performance of adding large numbers of Nodal, Elemental and 
Geometric Loads and Geometric Constraints to the Data Table

Improved performance adding and updating columns in Data Table API object
• One example of adding a Freebody with over 800,000 lines of data went 

from around 19 minutes to 34 seconds (33X improvement)

Improved the performance of loading certain facetted geometry. 
• One model with complex surfaces showed an almost 50% speed 

improvement, in another about 27%.

Improved the performance of updating a mesh in the Meshing Toolbox when 
the model contained rigid elements and Propagate Sizing option is turned off
• Previously, unnecessary work was being done to find adjacent edges even 

though those would never be used
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Simcenter Femap 2301
Analysis and Solver Support – Analysis Monitoring Improvements

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Several enhancements 
have been made to 
monitoring and recovering 
results from analyses 
which have been launched 
from within Femap



Simcenter Femap 2301
Analysis and Solver Support – Analysis Monitoring Improvements
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Improved monitoring when analyzing multiple 
Analysis Sets at once
• Icon in Model Info tree to indicate if analysis 

was successful
• Green “Square” – Analysis is running
• Red “Square” – Analysis in analysis queue
• Green “Thumbs Up” – Analysis completed 

successfully
• Red “Thumbs Down” – Analysis did not 

complete successfully

• Analysis Monitor pane updates based on 
“active” Analysis Set in Model Info tree

• “Active Set” shown in Analysis Monitor and 
“Load Results” loads results for active set 



Simcenter Femap 2301
Analysis and Solver Support – Analysis Monitoring Improvements
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Context-Sensitive menu now offers:
• Continue Running Analysis Queue – offers 

ability to run next job in analysis queue if 
previous job failed

• Clear Analysis Queue – clears out the 
analysis queue (was available in previous 
versions, but has been enhanced to work 
with new features)

• Load Results – loads results from selected 
analysis set(s)

• Show Analysis Monitor Pane – opens the 
Analysis Monitor if it has been closed



Simcenter Femap 2301
Analysis and Solver Support – Analysis Set Manager Enhancement
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In the Analysis Set Manager, a brief description 
of the analysis which is to be run by a specific 
Analysis Set is now displayed in the main 
Analysis Set dialog box.

These descriptions are based on a combination 
of the selected Analysis Program and Analysis 
Type and include information which is likely to 
be familiar to users familiar with solver 
nomenclature.

For example, the description for:
Analysis Program = “36..Simcenter Nastran” 
and Analysis Type = “7..Buckling” shows a 
description of “SEBUCKL – SOL 105”



Simcenter Femap 2301
Analysis and Solver Support – Analysis Set Manager Enhancement

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Additional Examples:
Analysis Program = “36..Simcenter 
Nastran” and Analysis Type = 
“4..Frequency/Harmonic Response” 
shows a description of “SEDFREQ –
SOL 108” when set up for a Direct 
Frequency run, while it would show a 
description of “SEMFREQ – SOL 111” 
when setup for a Modal Frequency run

Analysis Program = “5..ANSYS” and 
Analysis Type = “2..Normal 
Modes/Eigenvalue” shows a 
description of “ANTYPE,MODAL”



Simcenter Femap 2301
Analysis and Solver Support – Simcenter Nastran – Response Spectrum Application
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Added support for Simcenter Nastran’s 
simplified user interface for response 
spectrum application runs
• RSAPPLY case control command
• RSAPPLY bulk data entry
• RSPECTR bulk data entry
• RSPOPT bulk data entry

Includes support for the new modal 
combination methods
• CQC
• DSUM (FACTOR = Earthquake Duration)
• GRP
• ROSE (FACTOR = Earthquake Duration)



Simcenter Femap 2301
Analysis and Solver Support – MSC Nastran – HDF5 Output Request

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Output from MSC Nastran can now be requested 
in HDF5 format (NH5RDB) via the NASTRAN 
Output Requests dialog box

Depending on selected options, MDLPRM bulk 
data entry is written with appropriate value for 
HDF5 param

• Generate HDF5 (no other options on) – writes 2
• With Compression turned on only – writes 3
• With Input Data turned on only – writes 0
• Both With Compression and With Input Data 

turned on – writes 1 



Simcenter Femap 2301
Analysis and Solver Support – Simcenter Nastran – SOL 401

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Additions and Updates for Multi-Step Nonlinear (SOL 401) in Analysis Set Manager

• Boundary Conditions 
• Added Element Add | Remove drop-down to select Element Add | Remove 

entity or Element Add | Remove Set

• Multi-Step Control Options
• Changed default for Equilibrium Min Factor (EQMFMIN) from to 0.2 to 0.476
• Changed default for Equilibrium Max Factor (EQMFMAX) from to 5.0 to 1.9

• Multi-Step Control Options -> Solution and Convergence 
• Added Always Output Results at Last Converged Step (LSTCONV) Boolean
• Updated Diagnostic Level (MSGLVL) from Boolean to drop-down to 

accommodate additional option



Simcenter Femap 2301
Analysis and Solver Support – Simcenter Nastran – SOL 401

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Additions and Updates for Multi-Step Nonlinear (SOL 401) in Analysis Set Manager

• Multi-Step Control Options -> Contact/Bolt Preload
• Added Tangential Cont Stiff Options (KMODTN) drop-down
• Added Modal Subcase Scale (KMODSCL) value

• Multi-Step Control Options -> Creep/Plasticity
• Added Adjust Integration Factor (CRLIMR) value
• Added Max Equivalent Plastic Strain (PLLIM) value
• Added Max Plastic Strain Multiplying Factor (PLLIMF) value



Simcenter Femap 2301
Analysis and Solver Support – Simcenter Nastran – SOL 402
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Additions and Updates for Multi-Step Kinematics (SOL 402) in Analysis Set Manager

• Multi-Step Control Options
• Added Storage Cycle for Grid Point Results (IA16) value
• Added Storage Cycle for XY Plotting Results (IA19) value
• Added Ramping Load Factor Interpolation (RFVAR) drop-down
• Added Free Thermal Expansion (ITHE) Boolean
• Added Laws of Excitation Storage (LL2) value
• Added Max Equivalent Plastic Strain (PLLIM) value
• Added Creep Strain Increment (CRICOFF) value
• Added Adjust Integration Error (CRLIMR) value
• Update Enable Inertial in Dynamics (INERTIA) to drop-down to accommodate 

additional option
• Changed default for Minimum Decrease Ratio (EQMFMIN) from 2.1 to 0.476



Simcenter Femap 2301
Analysis and Solver Support – Simcenter Nastran – SOL 402
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Additions and Updates for Multi-Step Kinematics (SOL 402) in Analysis Set Manager

• Multi-Step Control Options -> Solution and Convergence Options
• Added Stiffness Update (KUPDATE) drop-down
• Added Max Time Step Reductions (MAXBIS) value
• Added Modified Generalized Alpha Param (RHOINF) value
• Added Tangential Contact Stiffness (KMODTN) drop-down
• Added Diagnostic Output (MSGLVLC) drop-down
• Changed default for Max Iter (ITMA) from 10 to 20
• Changed default for Relative Disp Force (PRCQ) from 1.0 to 0.1
• Changed default for Generalized Scheme Param (TETA) from 0.80 to 0.55



Simcenter Femap 2301
Analysis and Solver Support – ABAQUS
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Additions and Updates for ABAQUS

• Added support for SHELL TO SOLID CONNECTION for glued contact 
• Added support for 13-node pyramid elements, which are degenerate 

hexahedral elements
• Added support for NASTRAN RBE3-like interpolation elements
• Updated Standard Beam Section to write out for Implicit Analysis, not just 

Explicit Analysis.  Also corrected issues when reading standard sections 
from ABAQUS input file

• Updated reading of output files to read in Forces for Spring and DOF 
Spring elements, which are created using a STRESS request



Simcenter Femap 2301
Analysis and Solver Support – ANSYS

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

Additions and Updates for ANSYS

• Added the ability to read “meshed” cross-section for Beams from ANSYS 
input files and store them with the appropriate Beam Property so they can 
later be exported

• Added support to read in additional ANSYS APDL-style inputs which are 
often used in input files created by ANSYS Mechanical (formally ANSYS 
Workbench) and were not supported in previous versions
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Simcenter Femap 2301
Postprocessing – Computed Vectors

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.

The new Computed 
Vectors functionality 
captures additional 
key results data that 
may not be calculated 
by the solver via the 
Model -> Output -> 
Computer Vectors 
command



When To Compute (Two Options)
• Automatically when Results are Read or 

Created
• If Auto Run is specified for a results 

quantity, appropriate output vectors are 
always created when results are read or 
otherwise created

• Only vector with default set to Auto Run 
is Plate/Solid Principals and Invariants

• Now in Existing Output Sets
• Check boxes in Run Now column, then 

click Compute Now button to compute 
vectors

Simcenter Femap 2301
Postprocessing – Computed Vectors
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Computed Vectors (Two Types)
• Standard – Select from list of pre-defined 

output types
• User Defined – Choose from Envelope, 

Combination, or API Script, then define

Library of vectors to compute can be saved
• Both Standard and User Defined can be 

saved to libraries
• Loaded via icon from within command
• Set on Results tab of File -> Preferences 

to select a library of vectors to always 
compute for all new models

Simcenter Femap 2301
Postprocessing – Computed Vectors
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Standard Computed Vectors – Results 
quantities that many users has asked for 
Femap to compute

• Elemental Results
• Plate/Solid Principals and Invariants 

(Identical to Compute Principal 
Stress/Strain option on Results tab in 
File -> Preferences in previous versions)

• Plate Averaged Mid Stress/Strain 
(Identical to Compute Averaged Mid 
Stress/Strain option on Results tab in 
File -> Preferences in previous versions)

• Beam/Bar Von Mises Stress

Simcenter Femap 2301
Postprocessing – Computed Vectors

© Siemens 2023 | Siemens Digital Industries Software | Where today meets tomorrow.



Standard Vectors – Results quantities that 
many users has asked for Femap to compute

• Plate/Solid Failure Theory
• Max Von Mises
• Max Shear Stress / Tresca
• Mohr-Coulomb Stress
• Max Normal Stress

The “…” button opens the Plate/Solid Failure 
Theory Options dialog box
• Results to Use – Choose between Centroid 

Only or Centroid and Corner
• Design Safety Factor – Value used to 

compute Design Safety Factor for verification  

Simcenter Femap 2301
Postprocessing – Computed Vectors
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Standard Vectors – Results quantities that 
many users has asked for Femap to compute

• Laminate Failure Theory
• Hill
• Hoffman
• Tsai-Wu
• Max Strain

Uses same Failure Theory calculations as 
Nastran solvers

Allows user to calculate different Failure 
Theory or recalculate using different material 
limits without re-running the analysis 

Simcenter Femap 2301
Postprocessing – Computed Vectors
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Standard Vectors – Results quantities that 
many users has asked for Femap to compute

• Enveloped Results
• Beam All Locations
• Plate Top/Bottom, Laminate All Ply
• Plate/Laminate All Locations
• Solid All Locations

These results quantities could always be  
calculated using Model -> Output -> Process, 
this just streamlines the creation of these 
output vectors

Simcenter Femap 2301
Postprocessing – Computed Vectors
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User Defined Computed Vectors – Results 
quantities which have been defined by the user 
for a particular model 
• Computation Type

• Combine – Creates Computed Vectors 
based on a Linear Combination or RSS 
Combination using any number of 
specified Output Vector IDs

• Envelope – Creates a Max Value, Min 
Value, or Max Absolute Value Envelope 
using the specified Output Vector IDs

• API Script – Creates Computed Vectors 
based on an API script

Click Define to define Computed Vector item…

Simcenter Femap 2301
Postprocessing – Computed Vectors
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Simcenter Femap 2301
Postprocessing – Computed Vectors
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Combination API ScriptEnvelope



Once defined, each User Defined Computed 
Vector item is added to the list

Much like Standard Computed Vectors, the 
When to Compute option is used to determine if 
the Auto Run or Run Now column is available

If needed, the icons in the Update Selected 
section can be used to:
• Edit – Edits selected item in the list
• Delete icon – Deletes selected item in the list
• Move Up/Move Down icons – Moves 

selected item up or down in list should 
Computed Vector item lower in the list rely 
on other item higher in list for vector IDs 

Simcenter Femap 2301
Postprocessing – Computed Vectors
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Updated options for “Data Conversion” 
throughout Femap

Previously, there were three options:
• Average
• Max Value (actually “Max Absolute Value”)
• Min Value (actually “Min Absolute Value”)

Now, available options are: 
• Average
• Max Absolute Value (old “Max Value”)
• Min Absolute Value (old “Min Value”)
• Max Value (New!)
• Min Value (New!)

Simcenter Femap 2301
Postprocessing – Data Conversion options
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These Data Conversion options are now all labeled consistently and 
available in all places they are used:
• Contour Options dialog box
• Postprocessing Toolbox for Data Conversion
• View, Options – “Post Titles” (displayed in Graphics Window)
• Charting pane dialog boxes and Legend in Chart Area
• Model -> Output -> Process – Convert tab
• Output Map Data Surface in Data Surface Editor pane
• Model -> Load -> Map Output from Model command
• Entity Editor and Data Table which contain info about a View
• API Enum zResultsConvert
• API Interpolate Class

Simcenter Femap 2301
Postprocessing – Data Conversion options
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Support has been added 
to attach to HDF5 format 
results files (SCD5) 
generated by Simcenter
Nastran using the File -> 
Attach to Results 
command

Note: There is no way to 
currently request the 
SDC5 file from 
Simcenter Nastran via 
the Femap user interface

Simcenter Femap 2301
Postprocessing – Attach to Simcenter HDF5 File (*.scd5)
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Support has been added 
to attach to HDF5 format 
results files (NH5RDB) 
generated by MSC 
Nastran using the File -> 
Attach to Results 
command

Note: Results in this 
format can be requested 
within the Femap user 
interface via the 
NASTRAN Output 
Requests dialog box

Simcenter Femap 2301
Postprocessing – Attach to MSC Nastran HDF5 File (*.H5)
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HDF5 Output Types currently supported by Femap (May be more by time of release)

NODAL

• NODAL\DISPLACEMENT
• NODAL\APPLIED\LOAD
• NODAL\SPC\FORCE
• NODAL\MPC\FORCE
• NODAL\ACCELERATION
• NODAL\VELOCITY

Simcenter Femap 2301
Postprocessing – Attach to MSC Nastran HDF5 File (*.h5)
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ELEMENTAL STRESS

• ELEMENTAL\STRESS\ROD
• ELEMENTAL\STRESS\ROD\NL

• ELEMENTAL\STRESS\TRIA3
• ELEMENTAL\STRESS\TRIAR
• ELEMENTAL\STRESS\TRIA6
• ELEMENTAL\STRESS\QUADR
• ELEMENTAL\STRESS\QUAD4
• ELEMENTAL\STRESS\QUAD8
• ELEMENTAL\STRESS\QUAD\CN

• ELEMENTAL\STRESS\QUADR\NL
• ELEMENTAL\STRESS\QUAD4\NL
• ELEMENTAL\STRESS\TRIA3\NL
• ELEMENTAL\STRESS\TRIAR\NL

• ELEMENTAL\STRESS\TETRA
• ELEMENTAL\STRESS\HEXA
• ELEMENTAL\STRESS\PENTA
• ELEMENTAL\STRESS\PYRA

• ELEMENTAL\STRESS\TETRA\NL
• ELEMENTAL\STRESS\HEXA\NL
• ELEMENTAL\STRESS\PENTA\NL
• ELEMENTAL\STRESS\PYRA\NL

Simcenter Femap 2301
Postprocessing – Attach to MSC Nastran HDF5 File (*.h5)
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ELEMENTAL FORCE
• ELEMENTAL\ELEMENT\FORCE\ROD
• ELEMENTAL\ELEMENT\FORCE\QUAD4
• ELEMENTAL\ELEMENT\FORCE\QUADR
• ELEMENTAL\ELEMENT\FORCE\TRIA3
• ELEMENTAL\ELEMENT\FORCE\QUADR\CT
• ELEMENTAL\ELEMENT\FORCE\TRIAR
• ELEMENTAL\ELEMENT\FORCE\TRIA6
• ELEMENTAL\ELEMENT\FORCE\QUAD8
• ELEMENTAL\ELEMENT\FORCE\QUAD4\CN

Simcenter Femap 2301
Postprocessing – Attach to MSC Nastran HDF5 File (*.h5)
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ELEMENTAL STRAIN
• ELEMENTAL\STRAIN\ROD

• ELEMENTAL\STRAIN\QUAD\CN
• ELEMENTAL\STRAIN\QUAD4
• ELEMENTAL\STRAIN\QUAD8
• ELEMENTAL\STRAIN\QUADR
• ELEMENTAL\STRAIN\TRIA3
• ELEMENTAL\STRAIN\TRIA6
• ELEMENTAL\STRAIN\TRIAR

• ELEMENTAL\STRAIN\TETRA
• ELEMENTAL\STRAIN\HEXA
• ELEMENTAL\STRAIN\PENTA
• ELEMENTAL\STRAIN\PYRA

Simcenter Femap 2301
Postprocessing – Attach to MSC Nastran HDF5 File (*.h5)
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Simcenter Femap 2301
Postprocessing – Support for results from Simcenter Nastran SOL 401 and SOL 402
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Added support for results from 
Simcenter Nastran SOL 401 for 
Element Addition and Removal
• Pre-Born and Removed Elem Flag
• Activate-Deactivate Elem Time

Added support for various types of 
Strain results from Simcenter Nastran 
SOL 401 and SOL 402 for 
Axisymmetric, Plane Strain, and 
Plane Stress elements



What’s new 
Simcenter Femap 2301
Teamcenter Integration
Geometry
Preprocessing
Meshing
Performance Improvements
Analysis and Solver Support
Postprocessing
Miscellaneous and API
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Simcenter Femap 2301
Miscellaneous – Command Finder
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New for version 2301 is the Command 
Finder functionality!!!
• Accessed via the “Search Commands” 

field found in the menu bar to the right 
of the Help menu

• Type keyword(s) into field and 
available commands which contain the 
keyword will be listed after clicking the 
“magnifying glass” icon in the field or 
clicking Enter

• Navigate to the desired command in 
the list and the command will be 
invoked



Added new Computed Vectors Object (feComputedResultsVectors) 
along with adding required properties and methods to access the new 
Computed Vectors functionality programmatically

Added new Element Add | Remove Object (feElemAddRemove) along 
with adding required properties and methods to access the new 
Element Add | Remove functionality programmatically

Added feGroupReduceToExisting to provide programmatic access to 
the new Group -> Operations -> Reduce to Existing command

Added feMeshEditingSplit to access the Mesh -> Editing -> Split 
command programmatically

Simcenter Femap 2301
API – New functionality
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Added SolidCleanupTool Object along with needed properties and methods to allow 
programmatic access to all options in Geometry -> Solid -> Cleanup command

Added feSurfaceMidAuto5 to allow programmatic access to all options in the 
Geometry -> Midsurface -> Automatic command including new Remove Holes 
and Keep Untrimmed Surfaces options

Added feCurveSplitPointToPoint2, feCurveSplitPointToEdge2, and 
feCurveSplitEdgeToEdge2, each of which now has an option for determining the 
surface to be split:
• 0 = Works the same as the previous API calls (i.e.,without the “2) and if a surface 

to split is not found, user is prompted to choose one
• 1 = Attempts to determine surface to split automatically and if one cannot be 

determined, returns FE_FAIL
• 2 = Option to enter ID of surface to split via 4th argument in call 

Simcenter Femap 2301
API – New functionality
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Simcenter Femap

Simcenter Femap SaaS
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siemens.com/try-simcenter-femap

Try Simcenter Femap for free
30-day free trial
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Explore – Browse our different blogs
dedicated to each solution, read our 
articles and hear about the latest news.

Share – Ask questions in our forum, 
get answers, connect with other users, 
and benefit from their experience.

Learn – Find the information you need 
in the knowledge base and 
improve your skills.

Join the Simcenter Femap Community

siemens.com/plm/community/simcenter
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